Installing and using OpenWrt in VM box

Hi, i am using VM Box with debian latest image, while git cloning it is showing error fatal: **unable to access '': gnutls_handshake() failed: Error in the pull function.**

You apparently haven't configured the VM properly. Confirm that you have Internet connectivity and that the proper packages for TLS connections have been installed. Checking if you can, for example, wget would be a good first step.


Thanks jeff, I tried wget it didn't work.

it showed

 -2019-03-13 11:25:27--, 2404:6800:4009:808::2004
Connecting to ||:443... connected.
GnuTLS: Error in the pull function.
Unable to establish SSL connection.

Are you behind a proxy? Is your date correct?

Out of interest how did you install debian?

try without gnu-tls;

apt-get remove gnu-tls

then add;

apt-get install apt-transport-https

1 Like

Last time i tried to install it on VM Box. It was having some proxy issue.

Want to know if i don't have target board what shall i choose in make menuconfig,

i choose x86 but it is showing error:

recipe for target '/home/arun09/openwrt/openwrt/staging_dir/target-x86_64_musl/stamp/.tools_compile_yynyyyyynyyyyynyynnyyyynyyyyyyyyyyyyyyynyynynnyyynnyyy' failed
make[1]: *** [/home/arun09/openwrt/openwrt/staging_dir/target-x86_64_musl/stamp/.tools_compile_yynyyyyynyyyyynyynnyyyynyyyyyyyyyyyyyyynyynynnyyynnyyy] Error 2
make[1]: Leaving directory '/home/arun09/openwrt/openwrt'
/home/arun09/openwrt/openwrt/include/ recipe for target 'world' failed
make: *** [world] Error 2

Not the most helpful logs. What does make V=s show? I'm guessing you don't have all the needed tools on your build machine installed yet.

(The pre-made snapshots for x86_64 have installed easily for me under VirtualBox.)

1 Like

HI Jeff

these are last logs,

checking whether mkdir handles trailing slash... yes
checking whether mkdir handles trailing dot... yes
checking for mkdtemp... yes
checking whether mkfifo rejects trailing slashes... yes
checking whether mknod can create fifo without root privileges... configure: error: in `/home/arun09/wrtins/gitwrt/openwrt/build_dir/host/tar-1.30':
configure: error: you should not run configure as root (set FORCE_UNSAFE_CONFIGURE=1 in environment to bypass this check)
See `config.log' for more details
Makefile:31: recipe for target '/home/arun09/wrtins/gitwrt/openwrt/build_dir/host/tar-1.30/.configured' failed
make[3]: *** [/home/arun09/wrtins/gitwrt/openwrt/build_dir/host/tar-1.30/.configured] Error 1
make[3]: Leaving directory '/home/arun09/wrtins/gitwrt/openwrt/tools/tar'
Command exited with non-zero status 2
time: tools/tar/compile#21.47#7.67#31.64
tools/Makefile:152: recipe for target 'tools/tar/compile' failed
make[2]: *** [tools/tar/compile] Error 2

The build system needs only to be run as a regular user.

There is not a "root-required" install process for an OpenWrt build.

The preformatted button </> makes logs and the like much more readable


last error got resolved
now some automake error

missing aclocal-1.14 -I m4
recipe for target 'aclocal.m4' failed

Again, you must not build OpenWrt as root (UID 0), never - there is no excuse.

1 Like

i tried to do it without root, it's giving error

: cannot touch '/home/arun09/wrtins/gitwrt/openwrt/tmp/info/.files-packageinfo.stamp.d41d8cd98f00b204e9800998ecf8427e': Permission denied

Yes, because you did previous steps (git clone, downloading, configuring, etc.) as root before. There is no step in building OpenWrt that involves using root capabilities, neither git clone/ pull, the feeds installation/ update, nor invoking make.

Just do a fresh clone as normal user (not root, not sudo) and start again.