Installing and setting up on RPi 4

The fact that it's not connected to internet ... And I tried to close this bridge also and no connection. That is my concern. I would like to get out in the wild wild internet.

Yes. And that is default config that snapshots has. That is not the problem. The problem is that I don't have connection.

You either need a second ethernet device, like a USB TP-Link UE300, or you need to use VLANs with tags to split the one ethernet device into two VLANS eth0.1 and eth0.2 with eth0.1 in the br-lan and eth0.2 acting as the WAN. To do that you need a smart switch.

Alternatively you can make the eth0 into WAN but then how do you do LAN? You will have to use the wifi only, which is very weak on this device.

I'm connected to the same switch with this machine I write this and I'm getting DHCP no problem ... why wouldn't RPi get the IP then? It's not about any LAN configure yet. I'm just wanting to connect to the interwebs for now. And this is not working for some reason.

And as I wrote earlier. I have tried to disable bridge and made WAN with eth0 as interface and set it to use DHCP and still no connection.

Why?

reading back I see that you wanted to do USB tethering for WAN. right now you have no WAN interface, so no WAN IP address and nowhere to send packets to the WAN.

You need

which I guess is going to require you to set up some usb network kernel mods and things.

It looks like you're all set up except for the WAN/tethering. You might mark this solved, and open a new topic "how to set up tethering to my nokia 8110 for my RPi4" you could get someone with more experience in tethering.

Yes. When I got those packages and tools downloaded to the RPi, then yes this is my idea. But to get those packages downloaded it would be great to have internet connection over Ethernet, which I thought would work.

As I wrote in my earlier post in this thread:

And possibly some other packages too. Those kmods are not a problem those I have downloaded and can install as need be.

But I don't have problem with USB tethering ... I have problem to get my RPi online via Ethernet in order that I can get those packages and tools to get this USB tethering done.

I think it's not really productive to open another topic for something that is not problem here. What you think?

Yes, I understand your concern now. Do you have a serial console, or a monitor and keyboard or something? My concern is how are you going to issue commands on the device if you don't have a LAN connection? You can't have LAN and WAN coming off the same eth0 unless you have VLANs. Do you have a VLAN capable switch?

Thank you!

Those!

I don't need LAN yet as I said earlier. Now I only need to get this friggin thing online so I can get those packages downloaded and all tools I need set up. Then I will plug this 8110 to the USB and I don't need LAN and WAN from the same Ethernet then, am I?

so you simply need to create a WAN, and tell it to use eth0, and remove eth0 from the LAN bridge...

in /etc/config/network

config interface 'lan'
        option type 'bridge'
       option ifname ''
....

config interface 'wan'
      config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

Goes forward!

But now I encountered another problem.

I have installed all rndis and whatnot packages and installed LuCI and all.

I got things working so that I get connection via usb0 now. Also I get connection to LAN via eth0.

Only thing is that I have to set up eth0 IP manually after the boot even though my /etc/config/network is as follows:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd96:2cfb:8536::/48'

config interface 'lan'
	#option type 'bridge'
	option ifname 'eth0'
	option proto 'static'
	option ipaddr '10.0.0.1'
	option netmask '255.255.255.0'

confic interface 'usb_wan'
	option ifname 'usb0'
	option proto 'dhcp'

I commented "option type 'bridge'" out on purpose.

After boot I have to manually do

ifconfig eth0 inet 10.0.0.1

Then I get ifconfig like this:


eth0      Link encap:Ethernet  HWaddr DC:A6:32:5F:D2:34  
          inet addr:10.0.0.1  Bcast:10.255.255.255  Mask:255.0.0.0
          inet6 addr: fe80::dea6:32ff:fe5f:d234/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2261 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2171 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:231871 (226.4 KiB)  TX bytes:475873 (464.7 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:264 errors:0 dropped:0 overruns:0 frame:0
          TX packets:264 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:18661 (18.2 KiB)  TX bytes:18661 (18.2 KiB)

usb0      Link encap:Ethernet  HWaddr 32:FF:9B:B5:04:05  
          inet addr:192.168.0.11  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::30ff:9bff:feb5:405/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:162 errors:0 dropped:0 overruns:0 frame:0
          TX packets:102 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:14135 (13.8 KiB)  TX bytes:13388 (13.0 KiB)

Now I can connect via ssh or to LuCI.

But in LuCI I have not been able to add interfaces ... which is blocking me to get this thing to the point that I can get connection through RPi with my other devices connected to the same switch.

And no VLAN or any that stuff yet. I just need to get connections first.

This is what I see at this point in LuCI:

But as said cannot add any interfaces that I could use as relay bridge. Also I'm wondering why this interface is "marked for deletion"

Thanks for the assistance so far!

One learns new stuff and other things are still undone :smiley:

rather than comment out that option type bridge line, just delete it. does it work?

Leave LAN a bridge. There's no reason not to have it a bridge. LuCI may be expecting that so much that it doesn't work if it's not a bridge.

br-lan should have a static IP. You can connect wired ports or wireless APs to it. In a bridge all the attached ports are connected to the kernel through the main bridge br-lan here. Thus the DHCP server will serve wired or wifi users the same, and anyone can log in to OpenWrt on the br-lan IP address.

Generally if you're using a RNDIS usb-tethered phone for Internet instead of an Ethernet connection, just take the eth port off of wan and attach usb0 instead. Makes it simple to switch back and forth.

1 Like

No.

Not working as a bridge.

But how do I share this WAN connection to LAN then?

I don't want to switch between. I want to have this USB-tethered connection shared to devices in LAN. WIFI is not needed.

It's a ROUTER. It routes packets between LAN and WAN.

I wouldn't be here writing "It doesn't work if it would work.

But I do it again. I'll uncomment the bridge and reboot and check if it works. Still doesn't fix the fact that I have to manually set up IP to eth0 ...

Make it a bridge, and then you WONT HAVE AN IP ON ETH0 instead you will have an IP on br-lan, which is where it should be.

GOT IT WORKING!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.