Installing 19.07. RC2 on a Mikrotik RB433UAH

I'm following this guide
As you can see it's stated there:
"When using bootp, there is no need to reconfigure the RouterBoards using serial port: you can just force netboot directly using the RouterBoard Reset button"

My other mikrotik device doesn't even have a serial interface.

-I set an IP 192.168.1.11 on my computer
-In pxesrv.exe i set openwrt-18.06.5-ar71xx-mikrotik-vmlinux-initramfs.elf as a boot file
-In pxesrv.exe I set a DHCP server
-I shut down the mikrotik
-While holding the reset button I power on the mikrotik
-It gets an IP address from pxesrv.exe and also the information that it should boot the .elf file
-After that I connect the cable to a LAN port and access the device on http://192.168.1.1
-I then flash openwrt-18.06.5-ar71xx-mikrotik-nand-large-squashfs-sysupgrade.bin
-After that 18.06.5 is permanently installed on the device.

So is there a way to initiate erasing of flash if I access the device through ssh after it has booted or does this not make any sense?

This sounds interesting. How can I do that? :slight_smile:

The UAH has a reset button?

OK...your device must be different than mine...or that button didn't do what the instructions describe. I had to short a surface jumper in a hole; but never had to use the little button.

Also, that page didn't exist when I setup my device. Since you seem to insist on using it, I followed a guide similar to this part: https://openwrt.org/toh/mikrotik/common#methods_to_set_routerboard_so_it_will_tftp_netboot

I used Method 2; and to be clear I used TFTP/DHCP Boot, not PXE.

I mentioned no already. This makes 0 sense.

:man_facepalming:

OK...now I think this is a troll. You access that menu.

Yes. Mine has. It is shown on this photo

.

I meant what is the menu called and what value needs to be changed. I found info that it can be changed using winbox when running RouterOS.

OK, well, I wish you luck using Method 1.

Apologies I cannot assist more, I'm only familiar with Method 2. The issues you describe - I experienced before I erased the flash. After erasing, I again set TFTP to boot the ELF; and lastly entered LuCI and did a sysupgrade with the BIN to flash permanently. I've never needed to access the serial again.

Again:

It's also possible I didn't have a PXE environment available, but only TFTP. Nontheless, the only thing I had to press was the flat jumper hole:

Screenshot from 2019-12-18 09-54-52

As I noted, I didn't have access to the RouterOS (as you seem to), so I had to perform a factory reset. I'm not familiar with any Mikrotik tool (except to upgrade RouterBOOT, play with RouterOS, etc.). Since I had access to the board (no case) and a [null] serial cable, I initialized the TFTP boot from RouterBOOT, changed the CPU speed, turned off the buzzer, etc.

I hope all works out.

1 Like

Thank you. Your help is much appreciated.

1 Like

So I finally got my hands on a serial cable that works with my Mikrotik.
I tried to format NAND through the BIOS as you suggested.
After that tried booting 19.07.RC2 but I couldn't get it to boot.
Booted 18.06. and then upgraded to 19.07.
After that the device keeps going in loop.
In the console I can see this:

[    3.054043] NAND flash driver for RouterBoard 4xx series version 0.2.0
[    3.060874] nand: device found, Manufacturer ID: 0xad, Chip ID: 0xdc
[    3.067234] nand: Hynix NAND 512MiB 3,3V 8-bit
[    3.071666] nand: 512 MiB, MLC, erase size: 256 KiB, page size: 2048, OOB size: 64
[    3.079310] Scanning device for bad blocks
[    3.158919] Bad eraseblock 479 at 0x0000077ff800
[    3.375876] Bad eraseblock 1844 at 0x00001cd3f800
[    3.403720] Bad eraseblock 1993 at 0x00001f27f800
[    3.417289] Creating 3 MTD partitions on "NAND 512MiB 3,3V 8-bit":
[    3.423477] 0x000000000000-0x000000040000 : "booter"
[    3.429995] 0x000000040000-0x000000400000 : "kernel"
[    3.436296] 0x000000400000-0x000020000000 : "ubi"
[    3.446603] libphy: Fixed MDIO Bus: probed
[    3.453884] IP17xx: Found IP175D at ag71xx-mdio.0:00
[    3.461449] libphy: ag71xx_mdio: probed
[    3.806071] ag71xx ag71xx.1: connected to PHY at ag71xx-mdio.0:04 [uid=02430d80, driver=Generic PHY]
[    3.815743] eth0: Atheros AG71xx at 0xba000000, irq 5, mode: rmii
[    4.259683] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.0:00 [uid=02430d80, driver=IC+ IP17xx]
[    4.269293] eth1: Atheros AG71xx at 0xb9000000, irq 4, mode: mii
[    4.277204] NET: Registered protocol family 10
[    4.285926] Segment Routing with IPv6
[    4.289669] NET: Registered protocol family 17
[    4.294140] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    4.307126] 8021q: 802.1Q VLAN Support v1.8
[    4.311423] rb: no calibration data found
[    4.318830] UBI: auto-attach mtd6
[    4.322148] ubi: refuse attaching mtd6 - MLC NAND is not supported
[    4.328369] UBI error: cannot attach mtd6
[    4.333000] VFS: Cannot open root device "(null)" or unknown-block(0,0): error -6
[    4.340534] Please append a correct "root=" boot option; here are the available partitions:
[    4.348877] 1f00              44 mtdblock0
[    4.348881]  (driver?)
[    4.355418] 1f01               4 mtdblock1
[    4.355421]  (driver?)
[    4.361943] 1f02               8 mtdblock2
[    4.361946]  (driver?)
[    4.368473] 1f03               4 mtdblock3
[    4.368476]  (driver?)
[    4.375002] 1f04             256 mtdblock4
[    4.375005]  (driver?)
[    4.381530] 1f05            3840 mtdblock5
[    4.381532]  (driver?)
[    4.388059] 1f06          520192 mtdblock6
[    4.388062]  (driver?)
[    4.394579] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[    4.403707] Rebooting in 1 seconds..

This part here seems strange: "ubi: refuse attaching mtd6 - MLC NAND is not supported"

Do you know what this means?

One thing at a time.

  • Can you try to boot flash and check stability on 18.06.5 first
  • Then, we can work on 19.07-rc2?
  • Did erasing work?
  • What errors did you received when you tried?

Erasing worked. Then I tried to install 19.07 through dhcp/tftp. That didn't work.
I then booted 18.06 and that worked right away. After getting 18.06. I tried upgrading to 19.07.
After this upgrade the router was looping and presenting the error I posted above:
ubi: refuse attaching mtd6 - MLC NAND is not supported
I found this page where the same thing is discussed and it seems it is realted to the MLC NAND not being supported.

1 Like

So again:

  • Boot 18; and then
  • flash 18

Let's verify the hardware's working properly on stable v18. And to be reiterate, I'm running 19.07.0-rc2 just fine.

Yes, version 18.06. worked and works fine. Now I booted 18.06. and flashed 18.06. and it is working with no issues at all.
By the way in your screenshot it says 433/AH. Is that the same as 433/UAH like the one I have?

I previously mentioned no, the AH only has 64 MB flash, yours is larger.

We previously discussed that when I noted that you should be using the large image; and that I would use 64m.

Are you using the large image?

Yes, I'm using the large image.

1 Like

OK....good...

:smile:

Now, I'm curious, does 64m v19 boot for you then???

Nope :slight_smile: Tried once when you mentioned that you are using it but it wasn't working as well.

I'm out of ideas...that bug report may apply to you...after all, we do have different flash chips...

:thinking:

1 Like

Apparently it was never supposed to work so I'm puzzled how it is working on your device.
I asked in the thread for 19.07.RC2 release and was told that support for MLC NAND was dropped in 19.07.

Yes, its normal.
MLC NAND flash was never supported officially in UBI.
It was still working in 18.06 and I fought to keep support throughout all point releases, but it was agreed to follow upstream on this matter and drop it after 18.06
You can make your own 19.07 build and add the patch from that commit, but it's at your own risk with zero support.

This issue was seen before with Mikrotik hardware.

They sometimes switch components on the board without any noticable change for us in the model or versioning, as confirmed by their support dept. (cost-saving or supply issues .. who knows)

You can probably confirm this by comparing the bootlog from a working and non-working board.
I suspect you will see 2 different flash chips (one being MLC, one being more expensive SLC)

1 Like

I'm not puzzled.

[    1.147308] NAND flash driver for RouterBoard 4xx series version 0.2.0
[    1.154075] nand: device found, Manufacturer ID: 0x20, Chip ID: 0x76
[    1.160452] nand: ST Micro NAND 64MiB 3,3V 8-bit
[    1.165102] nand: 64 MiB, SLC, erase size: 16 KiB, page size: 512, OOB size: 16

Yep, SLC.

1 Like