Installing 19.07. RC2 on a Mikrotik RB433UAH

I have a Mikrotik RB433UAH currently running 18.06.
What is the correct procedure to upgrade to 19.07 RC2?
I tried to upgrade through the GUI by flashing openwrt-19.07.0-rc2-ar71xx-mikrotik-nand-large-squashfs-sysupgrade.bin but that didn't work.
I tried the same with no settings preservation and it also failed.
I tried to network boot using openwrt-19.07.0-rc1-ar71xx-mikrotik-vmlinux-initramfs.elf but that didn't work either.
In all cases it seems like the device gets in a boot loop. It keeps beeping (like it does when booting) but it never boots properly.

As far as I know, there is no procedure. Maybe others can chime in. I'm an owner of a RB433AH, so I've been following this.

  • the Mikrotiks on ar71xx have not been ported to ath79
  • ar71xx was made "end-of-life" in June 2019 on the master snapshot
  • I noticed that the ar71xx avalaiable under RC2 was last compiled on December 1st


1 Like

So if I understood you correctly there is currently no way to install 19.07 on Mikrotik RB433UAH?

To be clear:

  • 19.07 has not yet been released, so not at this time
  • If you're referring to RC2, since here's no [working] image for such devices, no (but I provided the links for you to draw your own conclusion and to see the reasons/progression)

Yes, I was referring to RC2 since I saw that there are files published for AR71XX/Mikrotik

Yes, this is why I hope others chime in; but I will test on my device...

RC2 works!

BusyBox v1.30.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 OpenWrt 19.07.0-rc2, r10775-db8345d8e4

So, I guess we need to troubleshoot your installation/upgrade.

This is an error on my part, as this was a 2nd RC, it was built on December 1; and won't be updated. Apologies for the confusion.

Is this on your router? If yes how did you upgrade? What file did you use?

Ummm, yes, I noted I owned a RB433AH. So, I tested to verify if I too had an issue. I did not have issues upgrading.

cd /tmp
sha256sum openwrt-19.07.0-rc2-ar71xx-mikrotik-nand-64m-squashfs-sysupgrade.bin
# I verified the sum outputted matched the downloads page

sysupgrade openwrt-19.07.0-rc2-ar71xx-mikrotik-nand-64m-squashfs-sysupgrade.bin

See codebox.

I'm trying to do the same as you but it doesn't work.
I verified the checksum and it was OK.
Then it says:

root@OpenWrt2:/tmp# sysupgrade openwrt-19.07.0-rc2-ar71xx-mikrotik-nand-64m-squashfs-sysupgrade.bin
Image metadata not found
Saving config files...
Commencing upgrade. Closing all shell sessions.

After that I lose connectivity. The device does not reboot. I tried rebooting it myself.
It seems that it cant boot. If I have a PXE server running it starts downloading an image to boot.
I again installed 18.06. through PXE then again installed 18.06. and again tried upgrading to 19.07. but it was the same.
I have a second Mikrotik device running 18.06. (RB951Ii-2HnD) and it acted the same when I tried to upgrade.

  • To be clear, the UAH uses the large firmware; but the 64M should work for you too - you can always reference the device's page
  • Are you saying you can PXE boot 19.07.0-rc2?
    • If so, can you just try to boot the 19.07.0-rc2 image then sysupgrade it while running?

No, PXE boot works only with 18.06. I'm unable to PXE boot with openwrt-19.07.0-rc2-ar71xx-mikrotik-vmlinux-initramfs.elf

Now I'm also unable to install 18.06 :frowning:
I can pxe boot 18.06. but after installing 18.06. it acts the same way as with 19.07.
It doesn't reboot and if I connect a pxe on the Eth1 port it imidiately starts downloading the boot file like nothing is installed.
Is it possible that the file system is corrupted?

OK, something's definitely not rite here...or you're skipping steps out of repeated frustration.


I'm completely lost. At this point, I think you should start over as a fresh install.

  • I thought you were flashing from scratch, so what file system?
  • Can you run an erase flash command on the Mikrotik RouterBOOT serial menu - before trying to PXE boot and flash?

I managed to install 18.06 again. I reverted to mikrotik original firmware using mikrotik netinstall.
Then booted 18.06. through PXE and then installed 18.06.
Tried PXE booting 19.07. or upgrading from 18.06. but it wont do it. The device in both cases keeps rebooting and beeping.

Also tried with 19.07 RC1 and it acts the same :frowning:


  • Why did you install RouterOS?
  • Are you under a belief this is required to install 18.06?
  • Are you erasing the RouterOS (and the flash) instance prior to the OpenWrt install?
    • If not, that may be the source of your issues
  • Have you read the installation instructions on the device's page?
  • Did you do what I advised:
  • I have no clue what you're trying!

Let's start with:

  • erasing the flash; then
  • PXE booting version 19

I installed RouterOS couse I thought there is something wring with the file system and that installing routerOS would fix that. I know it is not needed to install 18.06.
I am not erasing the flash. Do I need a serial cable connection to be able to erase the flash?


So yes. You should have a serial port on your device, between the WAN port and LAN ports. If you've never accessed that serial port, I'm unsure how you originally installed OpenWrt anyway.

Again, there shouldn't be a file system, as you're clearing the flash. It seems like this may be your issue.

Serial port is not needed to install openwrt. My other Mikrotik device (RB951Ii-2HnD) doesn't even have a serial port built in.
I set a pxe server, power off the device, hold the reset button and then power the device on. It automatically picks an IP address and the boot file. I never needed a serial interface to deploy openwrt.
Can I erase the flash on a booted device when connected through SSH?

At the point-in-time I'm referring to, your device shouldn't be booted, hence no SSH access, so no. The menu I'm referencing is much like a BIOS screen on a x86_64 device.

I most definitely had to access the serial on my RB433AH. Are you sure you're not installing OpenWrt as a Virtual Machine?

That won't work.

(And if you access the menu I'm referring to, you can also increase your router's CPU to 800 MHz.)

How are you setting a PXE server if you never accessed the RouterBOOT (i.e. the bootloader) menu?

In RouterOS?

(Maybe I should note, I didn't have access to the RouterOS when I purchased my device, you keep making references as if you're changing settings in the OEM Mikrotik OS I never used.)