Installed OpenWrt on TP-Link Archer c2600 - Wireless access working, no internet when logging in via SSH

Hi everyone,

Just installed OpenWRT on my C2600 V1

Got access just fine and I can connect perfectly via the Wireless interface, that works great.

Logged in via SSH to install OpenVPN and when I try to do opkg update I get an error saying

Failed to establish connection

When I try to ping anything, I get an error "bad address"

I've tried editing the config for the LAN to include my IPv4 gateway and that hasn't helped.

Again, no problem when connected via Wireless, just when I'm connecting to the device via SSH

The system I have set up is that the router was previously connected as an unmanaged switch to my ISP's modem, so it's entirely possible I just don't know enough to have properly adjusted the settings.

I know I've likely not provided enough information, so please feel free to rake me over the coals with this and tell me what I'm missing.

Thanks so much in advance.

Assuming you have a somewhat typical setup, make sure you have you're gateway and DNS settings under your lan connection set to your internet wan IP address. Go to "network", "interfaces", and "edit" for your "lan". In my case, my OpenWRT is acting as a dumb AP and it is set to, while my internet connection is set to You should be able to use this address for your gateway and custom DNS server settings.

1 Like


Just to understand, you haven't installed VPN yet. All you did is installing OpenWrt, and now you have access to the router but no internet?

Could you elaborate on how are you connecting the modem to the router?

What happens if you go to (or whatever the router's IP is) and try to ping and also

Could you post the output of the following commands form SSH? Don't forget to mask out you MAC addresses. After you have paster the output here, use the Pre-Formatted text tool </>`to format the text.

Sweet baby jeepers

Yeah. So I guess pushing my router IP under gateway wasn’t enough.

Specified it as my DNS ( weren’t working) and bam, working now!

While I’ve got you awesome people here, I installed OpenVPN via opkg, I presume if I restart the router it will be available in the menu options there?

What I’m wanting to do is turn this AP into a VPN router so I can get access to geo restricted content. I would be connecting to my vpn (Nord) in order to access this, but I’m hoping I can access it via the router admin page, I installed open VPN via opkg install OpenVPN, I’m in the process of rebooting the router now

** okay, so I am stupid. I think I have it figured out. Need to sleep and follow the instructions from Nord about setting it up. Wew. That was a journey.

You would need to also install luci-app-openvpn package for the GUI.

Well, normally you shouldn't need to specify DNS, as the router should get what's supplied by ISP (unless of course you want to use a specific DNS). Putting DNS is a work around, but you may wish to look into why it's not working.

1 Like

Thanks so much for all the help, I think I'm getting there, connection is working perfectly now but I'm struggling to get NordVPN up and connected properly. I don't get any errors, but I also can't connect to the VPN when I connect via wireless (it shows my ISP assigned IP address)

I made a new post to keep things properly organized here:

I'd love any help or advice if you have any. Thanks SO much in advance. Hands down one of the most responsive tech forums I've submitted questions to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.