Installation on UBNT nanostation M5, recent firmware

Hi All,

I imagine this request raises some difficulties in the community around it, but I was having trouble finding a definite "its impossible" post anywhere, so hopefully this post will change that.

I have a ubiquiti nanostation M5 (XM version board) which was shipped to me with airOS firmware version 6.x.x installed. I am trying to use the device as a station/client to connect to an access point which requires connecting with EAP-GTC. I have asked on the airOS forums, and this type of authentication method is not supported on airOS. Therefore, I thought in order to solve the problem, I would start trying to do some hacking on openWRT in order to connect to this access point if GTC auth is not already supported by default.

This is where the nightmare began. There are many conflicting and outdated reports out there about how to flash UBNT ; the problem is in general after some version (5.6.x I believe) of airOS, only 'signed' firmware is able to be flashed. There do not seem to exist any 'signed' firmware prior to this version, and none of the methods I have found online allow you to bypass this signing restriction to load openWRT.

Things I have tried:

-reverted from 6.x.x to 5.6.x (the earliest 'signed' version available), and tried to load earlier firmware from the web interface. (gives 'untrusted' error)
-booted the nanostation in TFTP recovery mode and used tftp client to try to push either 5.5.x airOS or openWRT. ("Error code 2: Firmware check failed" after upload)
-booted normally and used ssh to copy over 5.5.x version, and tried to start update using ssh following this guide ( (get "Firmware update file check failed!" in the ssh session)
-found that the binary in /sbin/fwupdate was actually a shell script, and the check was a separate process/program. copied /sbin/fwupdate to /tmp/fwupdate and edited the sh script to not perform the check. (device said it updated and rebooted, but it was just back at 5.6.x again after this)

I believe I am getting out of my league here ; does anyone know in the community if anyone has successfully found some way to load / get back to older firmware on these devices, or am I stuck with something useless for my purposes?

thanks for reading my query!


I would also be very interested to know if anyone has gotten this to work on newer devices.

I have a nanobeam M5 400 that I am trying to load a fork of OpenWRT on, and I am running into the same issue...

The solution to my problem was to find a project with more recent updates.

I was able to successfully flash the PowerBeam M5 400 with the newer forked firmware.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.