Installation on GL-AR300M

Hi,

I am trying to install openwrt on a GL-AR300M following https://openwrt.org/toh/gl.inet/gl-ar300m.

Because this is a older device I had to update uboot via mtd, as documented at the bottom of the wiki-page which worked.

I then uploaded openwrt-22.03.5-ath79-nand-glinet_gl-ar300m-nand-initramfs-kernel.bin via uboot and the system updated.

The process seems to have come to an end, there is no more led-activity, all 3 led show a steady green, however I cannot connect via telnet 192.168.1.1.

The device has now been in this state for about 10 minutes.

Should I wait longer, try the update again or do something else?

Telnet died years ago, ssh is the new thing.

The wiki page says that this is the way to set a root-password.

Then I guess the wiki is outdated.

So how to I proceed?

What account? What address?
"ssh root@192.168.1.1" does not work.

From the Wiki:

  • or browse to http://192.168.1.1 if LuCI is installed.

You will notice that the router is running in safemode. In order to leave it, one must now flash a regular image factory or sysupgrade (e.g. glinet_gl-ar300m-nand-squashfs-factory.img) from shell or luci. After this second flash, the router will boot normally.

Did you try the web GUI?

To be clear, unless I've mistaken, you haven't permanently flashed OpenWrt yet.

So this comment seem premature, and since ypu were never seeking support with OpenWrt firmware, slightly erroneous.

2 Likes

Of course I have also tried the web-interface.

There is nothing on 192.168.1.1: No telnet-server, no ssh-server, no web-server.

I have tried several times and the documented procedure does not work on my device (I think there are several version of the AR300M).

The firmware does not seem to boot properly - for whatever reason.

But it does seem to have had a lasting effect in that now when I try to flash images provided by GL-Inet the device no longer boots in NAND-mode.

What was the exact file name of:

  • the file you used for initial installation
  • the file that you used for the upgrade to 22.03

And did you keep settings when you ran the upgrade?

I don't quite understand your question.

The file I used is stated in my initial post - openwrt-22.03.5-ath79-nand-glinet_gl-ar300m-nand-initramfs-kernel.bin.

And this was supposed to be the initial installation of openwrt. The device was running on gl-inet firmware before.

My understanding was that installing openwrt would be a multi-step process where you start with the above file and flash that via uboot which should give you a rudamentary system and once that runs you flash a factory image or a sysupgrade - is that a correct understanding or did I get something wrong?

My expectation was that flashing the above file would boot into a system that provides ssh-access on 192.168.1.1 but this is not the case. The device does not expose any service and all I can see it that while leds are blinking on start-up it eventually settles into a state where I have 3 green leds but no way to access the system - I assume it does not boot properly.

You flashed this same file using the sysupgrade process? That is your problem. You need to flash the file that has sysupgrade in its filename. I don’t know what happens when you flash the initramfs file this way, but this does explain why things aren’t working.

I flashed this file via uboot as desribed in the wiki.

All I can use at the moment is uboot - so which file should I try?

Did you flash it twice? You need to use the initramfs image to get OpenWrt running initially, but that image is not persistent. Immediately after you get this booted, you need to upgrade using the sysupgrade version.

I think I also tried that, but I will try again.

It seems to me that the wiki-page is wrong in several aspects (starting with documenting that you get telnet-access).

So if (contrary to my reading of the wiki) the system does not provide ssh-access after the first flash then how do I know when it is finished and when to start the second flash?

And can you confirm that the file I used is the correct one of the first flash?

But this is my problem: The first flash does not result in a booting system.

have you set astatic address to your pc? 192.168.1.2

Yes. I could not access uboot without it.

do you have the version with two external antenna?

No. I have a pretty old model without external antennas.