Installation on AVM FRITZ! Box 7530 uboot loading error

Hi guys,
I'm trying to install Openwrt on the fritz 7530 following the guide, but I am stuck at the first step; I deactivated dhcp on the router, static ip on the pc, in one terminal I ping and it answers me without problems, in the other I give the command

./ --offset 0x8500000 uboot-fritz7530.bin

but I get connection refused response; I tried both from windows (Winerror 10061) and from ubuntu (Errno 111); am I missing something?

the fritzbox is equipped with the latest firmware 7.29; is there anyone who has managed to install openwrt who can tell me with which firmware version? eventually I do a downgrade and try again

I'm not sure, but I think you are too late, when you wait until ping responds. The name 'eva_ramboot' suggests that it hooks in at the bootloader, eva. Don't know if that responds to ping.
So instead you should watch the LED on your NIC. As soon as it reports link, run the script.

1 Like

Hey @skid99

i am newbie to openWRT, but i also want to flash my fritzbox 7530 (actually hardware is at 7520, but i managed to upgrade it to 7530 firmware with its recovery tool). Running on version 7.29. I was not able to execute the eva script.
Today i downgraded to version 7.14 (thanks wayback machine) and tried again. As soon as you power on the FRitzBox connected to your PC and you see the very first Ping arriving, you have to send out RIGHT AWAY the script command. This will work and push the uboot to FritzBox.

However - I am stuck at step 6 of the installation. It seems that the Firtzbox received the firmware into the RAM (I can call in browser and lua CI link appears). However no further UI is loaded nor can I get via SCP the files to the fritzbox (SSH times out).

Have you been able to install this already?

Looking forward to hear from you!

Hi drunkdev1991,
now I'm a bit busy and I haven't had time to dedicate to him anymore; I had tried with the 7.13, but I wasn't able, maybe I'll try again as soon as I have some time; I haven't found 7.14, do you have a link to download it that I can try again as soon as I can?

Using Wayback machine I used this recovery file:
Nothing new from my side either, still stuck at SSH ... My guess would be probably some FTP parameter which is not set yet could enable SSH access. This requires further reading though, will tackle end of the week one more time. If this does not work, or I will not find further suggestions on the net, I will blame the hardware :smiley:

I managed to install Openwrt 21.02 on FritzBox7530 with latest firmware 7.29. I was not able to port it using a Linux system. It always got stuck in step where tftp transfer happens.Tried for over a month and gave up. Just yesterday tried all over again.

What worked for me was performing the installation on a windows machine, that too after temporarily disabling the firewall. With firewall enabled i was not able to transfer files using tftp. Disabling the firewall worked like a charm. Make sure to change the ip address of PC as, other ips didn't work out(for example

Oh, i tried this same steps with version 7.21 and 7.29 and it worked on both. So no need to downgrade if you're in version 7.29.

Tools needed: tftp32 or tftp63, winscp, putty.
All the steps are as given out in openwrt 7530's installation page. Hope this helps.

1 Like

@skid99 if you have connected your 7530 directly to PC, then don't wait for ping to come up, it would be too late as mentioned by @Mijzelf . 7530 would have moved past the bootloader time (i read it was around 5 seconds) and so you need to hook into the bootloader at the earliest.

Option 1: once you're about to unplug power from 7530, keep eva_ramboot ready and hit it again and again after plugging the power cord. This might work, but not at all times.

Option 2: If you have a dump switch, then connect this switch to your PC and connect your 7530 to this switch, Fritzbox7530->dump Switch->PC. This keeps the line active and once you plug in power to 7530, it would mostly able to talk to your PC quickly. Now hit the eva_ramboot command. This works almost all the time.

Option 3: If you don't have a dump switch, then grab the file, modify it to accept your PC ip address and run it first. When it says hit enter, press enter. It should start to check for the device and once you plug power to 7530, would pick it up and tries to load the u-boot file. Of course this step would fail. This is when you need to run eva_ramboot command in a separate terminal. Basically, file holds on to the bootloader so that you can use eva_ramboot command can do its job. Many time this has worked for me, even though i prefer option 2.

Try it at your own risk !

@sat unfortunately I lent my 7530 and I have to stop trying; thx