Installation Correcness Check

Hi I have Installed Open WRT Recently On Archer A7. Struggled a lot and successfully got connected to Internet and WIFI Setup also done. However I have still doubts about the correctness of my setup.

My Network setup is as below:
Fiber Network ISP Provided Router ->-> Archer A7 WAN Port ->-> Archer A7 Lan Port Supplying IP's to Devices On LAN.

Can I create eth1 and tag it to WAN instead of eth0.2?

Is VLAN Mandatory in OpenWRT for Getting Internet through WAN Port. I am new to VLAN (but understand what VLAN is for) Can someone let me know what is Tag and Untag.

Unable attach more than one Screens as I am a New User of this Forum.

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix '

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'eth0.2'
	option macaddr '00:XXXXX

config interface 'wan'
	option device 'eth0.2'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.0.2'
	option netmask '255.255.255.0'
	option gateway '192.168.0.1'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 2 3 4 5'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 1t 2t'
	option vid '2'

Please let me know if some changes to be done.

This is a mix of the old and new configuration syntax. What version are you running? I would suggest running version 23, resetting the config to default and working from there. Most fiber ISP uses IPoE DHCP which is supported by the default configuration.

To answer the original question, the five Ethernet ports including both wan and lan on the back of a C7 are connected to a separate switch chip which feeds into one CPU port. Tagged packets with VLANs 1 and 2 are used over this internal connection to keep lan and wan functions separate. The internal connection is switch port 0 and CPU port eth0.

1 Like