Install VOIP Server (missing packages?)

Hey Guys :slight_smile:

First of all: Thanks to all developers and other helping members for this great Fork, Good work.

Problem: On OpenWRT I used luci-app-pbx (
and asterisk18 packages (I think it was Version 1.8?).
This worked like a charm.

Now on LEDE the luci-app-pbx package is missing, maybe because of missing development on it ?
And there are no more asterisk18 packages.

I tried to get it working on LEDE with these packages: luci-app-asterisk and luci-i18n-asterisk-de (from opkg repo). But this didnt install any depencies (no asterisk install).
So I installed the missing asterisk packages manually (asterisk13 packages) and tried to configure it thru luci webinterface. But I dont get my SIP trunks running (no registration), I think luci-app-asterisk didnt work with asterisk13 together ? I dont know it really, because "sip show peers" command is not found in this asterisk version.

Anyway... is there a similar way to get voip working or get luci-app-pbx working on LEDE ?

LEDE Version: 17.01.0
Hardware: TP-Link Archer C7 V2 (without newer chip: gd25q128)

I hope some of you can Help me out of this, would be great :slight_smile:

[quote="MisterT, post:1, topic:2086"]
is there a similar way to get voip working or get luci-app-pbx working on LEDE ?
[/quote]You might get luci-app-pbx working if you update it to work with the currently available Asterisk versions. So far nobody (of asterisk users) has been interested enough to fix it.

The luci-app-pbx Makefile has been marked broken, because it depends heavily on the ancient deprecated asterisk18 packages that are not available in the Telephony feed repo (like you already noticed).

Same goes for luci-app-asterisk. It is ancient and unmaintained. Probably originally built similarly for ancient asterisk versions. Probably it should be marked broken, too.

Both apps would require that some asterisk user fixes them.

Ok, understood. Thanks for your reply :slight_smile:

I am not that asterisk pro to fix this :confused: I also heard to fix something in asterisk package is not that easy, because asterisk is more complex

Is there another sip server running on LEDE ? I am only need g711 ulaw + alaw (need it like a relay sip server).

Hi ,
When im trying install luci-app-pbx ,it is failing to install because of some dependencies,,so anyone tell me how to install luci-app-pbx in LEDE?

Short answer: you can't.
It is broken. Read advice above.