Install version 21.xx


I am trying to install openwrt 21.xx and while 19.xx allowed me to connect via ethernet using the initial openwrt access point it is not happing for version 21.xx. Anyone whom has managed to connect to 21.xx able to offer any advice?



What device? Did you preserve settings? In some cases, the settings from 19.07 are not compatible with 21.02, so keeping settings will cause problems.

Try failsafe mode and then use it to reset to defaults.

This is totally fresh install because I tried updating 19.04 to 21.04 before using following a YouTube video which ended in failure. If I knew where the initial openwrt access-point data was I might be able configure it via my Ubuntu pc although, I have notice that both network and wireless config files fail to show up under Ubuntu although when I sshed into 19.04 at least the files where there. I assume they are there in version 21.xx too, not able to verify because of not being able to connect to openwrt.

What device are you using? What firmware image did you download? Are you sure the device is actually booting?

Both network and wireless config files are created in the router at the first boot, based on a radio detection recipe. They are not in the build system (like Ubuntu).

But once you have done the configuration in a live router, you could copy the configured versions from your live router to the build system to have them included as "custom files" in your next build. See

Banana Pi R1, I am sure if it is booting or not because when I check the available networks when the Pi is plugged in to ethernet and turned on the network that should say "openwrt" says "unidentified".

Did you download the correct image? Did you write it to an SD card correctly (how did you do it)?

Do you get an IP address? Are you plugged into the right port on the device? If you're using Windows, the identification of the network by name is not really relevant and you may be assuming it is't working properly... the important thing is if you get an IP... and if you do, it should be in the network range. You'll then be able to open a web browser and visit and it should work, unless your Windows firewall is blocking things.

I am using BE on Win10 to flash the image. I assume the it would still should up using ipconfig with ip

It would be in the network, but the router itself would be at your computer would be something else.

Do you see anything showing up on that network adapter?


When I type ipconfig in the command prompt in Windows this is what I receive

Ethernet adapter Ethernet:

  Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::4ddb:4193:a7d3:2d09%22
   Autoconfiguration IPv4 Address. . :
   Subnet Mask . . . . . . . . . . . :
   Default Gateway . . . . . . . . . :

That indicates that the computer cannot get a DHCP response.

Have you tried the other ports?

Yes, and the first lan port is the only one that bothers to return data when the cable is plugged into it. I have just tried resetting the network setting on my laptop and even moving the rather annoying usb/ethernet/sd card hub for my laptop to other positions because Windows seems to have issues with it, but nothing works.

I have decided to stick with openwrt version:

Firmware Version

OpenWrt 19.07.10 r11427-9ce6aa9d8d / LuCI openwrt-19.07 branch git-22.099.58928-786ebc9

All the versions from 21.0.2 upwards all have the same problem with not being able to connect to openwrt.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.