Install Process For Unifi 6 Lite

i wanted to confirm the proper install process for OpenWRT on Unifi 6 Lite.
When looking at videos, I see people opening up the device.
But in the wiki it seems you do not have to. But it also says under construction so unsure if that changed.

It looks like I have to just plug the access point into my network, according to the article it seems I have to just check my firewall to see the IP it assigns it. Ssh into the ip.
Then just copy paste the following:

fw_setenv devmode TRUE
fw_setenv boot_openwrt "fdt addr $(fdtcontroladdr); fdt rm /signature; bootubnt"
fw_setenv bootcmd "run boot_openwrt"
scp openwrt.bin ubnt@IP:~/
cat /proc/mtd
dd if=/dev/zero bs=1 count=1 of=/dev/mtdblock4
dd if=openwrt.bin of=/dev/mtdblock6
dd if=openwrt.bin of=/dev/mtdblock7

Reboot and it should be up and running?

That's the correct procedure. I've done it a few times now after doing tftp recovery, and it works like a charm.

The fw_printenv and cat /proc/mtd commands are optional, but obviously there because you should sanity check the output before continuing. I.e. that your fw_setenv commands were successful and that the partition layout is as expected by the dd commands.

The Unifi 6 Lite is extremely failsafe in the way that the officially supported tftp recover method always works, without any need to open the device even if you "brick" it. But do make a note of the initial IP address when you do fw_printenv. Mine and several others were configured with a different address than the documented default. This is important if you need tftp recovery later, since the bootloader will use the configured address. Note that the default is reset to the first time tftp recovery is used, so this looks like some factory process problem. Possibly only affecting early devices.

You'll never need to open the Unifi 6 Lite. But it's actually not as difficult as it might seem in case you want to do it. I recently opened one of mine because I wanted to add console for better debugging, and was pleasantly surprised. Just use some flat tool without sharp edges and carefully force the plastic shell from the metal back. Both the glue (silicone?) and clips should survive and you can just snap it together again when you're finished.

1 Like

Good information thank you.
My only remaining question is surrounding the IP. This may be a stupid question but how arw you supposed to know the IP it has? Like when I connect it to my switch, I presume I will simply go into the switch/firewall and see what IP it is using?
My network uses 10.0.X.X not 192.168 so I am just curious if I will have trouble reaching it or need to do anything special. Its my first time setting up an AP from scratch on a network.

Actually I do have one more question.
Currently I do have an old router setup as an OpenWRT access point, going to my Opnsense box.
If I export the config, and import it on the Unifi Openwrt, is it smart enough to handle that?

I presume I'm going to run into issues with the ethernet port and need to figure out how to set it to tagged/untagged to match the config on my current AP. And Also maybe the wireless radios probably wont match up.
Just curious if you have any tips to make life easier so I dont have to manually reconfigure everything. I guess its doable though.

Some config can be re-used, but you'll run into problems in the areas you mention. I think it's easier to do start from scratch using your old config as cheat sheet.

As for the IP address: The vendor firmware defaults to, but will act as a DHCP client if connected to a network with a DHCP server. The boot loader will use whatever is stored in the uboot environment. This is supposed to be too, but is sometimes different. Still in the range though. OpenWrt defaults to

Ok makes sense.
I have gotten to the point of using scp to transfer the openwrt-22.03.2-ramips-mt7621-ubnt_unifi-6-lite-initramfs-kernel.bin file over to the device.
When I run scp openwrt-22.03.2-ramips-mt7621-ubnt_unifi-6-lite-initramfs-kernel.bin ubnt@ip it doesn't give any errors. When I ssh back in I do not see that file anywhere.
If I run find / -name .bin I do not see it. However if I do find / -name openwrt I see two results.

but I can't cd into them, and I don't see them when looking with ls -a /etc/
So I don't think it actually transferred over.
Maybe I should just wget the file while sshed in to make life easy. I presume there is no issues with that?
edit: well wget is not installed on mips and I don't know the package manager. hm..

edit2: just tried making a folder in the home dir for unifi called openwrt.
then transferring it in like such: scp openwrt-22.03.2-ramips-mt7621-ubnt_unifi-6-lite-initramfs-kernel.bin ubnt@ip:/openwrt
and it shows a progress bar and it completing. Then when I ssh back in and list all in that folder it still shows nothing..?

edit3: ok i realized my mistake. i wasn't putting a trailing slash so it was writing it into a file not the folder I specified. I got it haha.
So I finished the rest of the install, rebooted it and it flashed white for a little, then is now solid blue.
I'm just trying to figure out how to get into it now. Can't ping that original ip anymore, nor ssh into it. But I'm not seeing a new lease on my firewall. So idk.
if it is defaulting to then did I screw up because like I said my network is so I don't think I can access that. What's weird is my firewall seems to indicate that the lease for the original unifi ip is still active. But I can';t ping it, nor ssh into it, nor reach the web gui from that ip so idk.
edit: had to flush arp entry and it disappeared so it is not actually active lease for the mac anymore. but again still unable to figure out the correct ip and connect to it.

Ok i got it just by simply connecting it to my machine.
However I think I flashed the wrong bin because it says it is running in recovery mode. What is the proper way to flash the correct image? Can I just drag the proper bin over to the upgrade area in the gui?

Edit: ended up just flashing the correct image in web gui.
Seem to be all set, up and running .Thanks.
Just gotta figure out configuration. Kinda struggling a bit due to the differences in the AP, as my old one was a router with a switch and VLAN setup is different.