Install print server and linux client

Hi everyone,
I want to share a USB printer connected to my router.
Config: Desktop Opensuse 15.0, router TP-Link TD-W8970 with OpenWrt 18.06.1 r7258-5eb055306f / LuCI openwrt-18.06 branch (git-18.228.31946-f64b152), scanner/printer Brother DCP-7055
First I installed in USB local on the desktop with the Brother drivers. This part is OK
The I connected the printer to the USB router and followed the GUI Installing and troubleshooting USB Drivers, p910nd Printer Server, p910nd Print Server.
Now when I do
ls /dev/usb/lp* /dev/usb/lp0

netstat -an
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       
tcp        0      0*               LISTEN      

cat /etc/config/p910nd

config p910nd
option device '/dev/usb/lp0'
option port '0'
option bidirectional '1'
option enabled '1'
option bind ''

So looks good server side
Now I need to add a printer in the client side.
I tried what it in the guide using CUPS but nothing working. Manual method
DCP-7055 is not in the list.
I tried as well with Yast (Opensuse GUI), nothing good.

Does somebody could help me to fix that?

What client OS? It is slightly different for each OS.

See, for example, (Debian)

Client is desktop Opensuse 15.0
I tried with the wizard but maybe I didn't set the good way

socket:// should work from CUPS, but the binary brother driver might not make this easy (keep in mind that configuring scanner functionality is orthogonal to p910nd and needs to be done via sane).

1 Like

I owne a Brother DCP-7055
What I do
Home > Adding Printers and Classes > Add Printer
AppSocket/HP JetDirect
Make: Brother
Model: ??????
What model I should choose?
Or should I choose a ppd file?

This is how to install Brother driver on Linux client, for later reference.
After installing the server side with the howto, see first post
BTW, I tested it without the firewall rule, it's working fine.

From the Brother website, download the script for your printer that will install the driver.
For the DCP-7055 printer: linux-brprinter-installer-2.2.1-1
Open a terminal
Comments are [comment]

sudo bash linux-brprinter-installer-2.2.1-1 
[Enter password]
Input model name ->DCP-7055
You are going to install following packages.
OK? [y/N] ->y
[Licence text]
Do you agree? [Y/n] ->y
[Licence Text again]
Do you agree? [Y/n] ->y
[Script run wget]
Will you specify the Device URI? [Y/n] ->y
0: ipps
1: ipp
2: beh
3: http
4: https
5: socket
6: serial:/dev/ttyS0?baud=115200
7: lpd
8: hp
9: smb
10: parallel:/dev/lp0
11 (I): Specify IP address.
12 (A): Auto. (usb://dev/usblp0)

select the number of destination Device URI. ->I [letter]
 enter IP address ->[enter the server ip address (OpenWrt router)]
lpadmin -p DCP7055 -v socket:// -E
Test Print? [y/N] ->y
wait 5s.
[Test page should be printed]
lpr -P DCP7055 /usr/share/cups/data/testprint
You are going to install following packages.
Do you agree? [Y/n] ->y
[Licence text]
Do you agree? [Y/n] ->y
brsaneconfig4 -a name=DCP-7055 model=DCP-7055 ip=
Hit Enter/Return key.

However the scanner is not working yet, I try to find a way.