Install partly failed on Asus RT-AC85P

Dear All,

It's the first time I attempted to flash my new Asus RT-AC85P using the designated factory image and using the SHH method.

After the installation I can SSH to the router and login as root. But I cannot access the luci web interface. It doesn't give me any error message via the web browser, it just loads and loads forever...

I reverted back to the OEM firmware and then tried again using the installation via TFTP method. Same results, I still cannot access the luci web interface.

I am also not able to access the internet. My asus router is connected to an ISP modem, which is set in bridge mode. With the OEM firmware I was able to access the internet just fine.

The asus router's DHCP works fine, so I do get a proper LAN IP assigned on my desktop. The router's 2g/5g WIFI doesn't work though, so I cannot connect other devices yet.

Via SSH I can see that the luci installation is in place and the uhttpd is running (I also restarted it a couple of times).

Please advise as this is the end of my understanding! Shouldn't all of this work out of the box???


network.@device[0].ports='lan1' 'lan2' 'lan3' 'lan4'

I guess you have installed the factory image (marked in yellow) instead of the one linked above in the table (marked in red), right?

No, I used the one you marked in red! Shouldn't I? I am confused.

The one you marked in yellow links to "
". This appears to be for the AC65P, I have the AC85P.

What is the difference in any case and why did I get so confused?

Don't worry, you have flashed the correct file.

You could try the method described here:
Problem with ASUS RT-AC85P after first flashing - #3 by MrLink

I flashed

I now have a working internet and luci web interface! Is it still necessary to update using ?

Also, my wireless cards are not recognized at all. Do I need to install plugins manually?

Yes, you should flash the sysupgrade.bin file as instructed in the link provided by @tmomas

ps. Initramfs is for temporary use. See this reference:

When I try to flash with the sysupgrade.bin file I get the message that

  1. My device is not supported by this image. Supported devices: asus rt-ac65p. The uploaded image doesnt contain a suppported format. Make sure that you choose the generic image format for your platform.
    • had to "force upgrade"*

After the flash, my modem is recognized as a RT-AC65P (instead of the actual RT-AC85P). Is that ok?

My 2 wirelesss cards are recognized as "Mediatek MT7615E bgn and MT7615E nac". From the specs I see that in reality it is a bit different MT7615N. Is that a problem?

I see the 2 wifi cards are working at 2GHz and 5GHz.

You downloaded the wrong sysupgrade.bin image.

There is one specifically for RT-AC85P in the wiki page for the RT-AC65/85P.

I believe you should be able to just flash the correct RT-AC85P sysupgrade.bin using LuCI. Do NOT 'Keep Settings' when prompted

If you are a Windows user, the wiki page does describe how to use the Asus Firmware Restoration tool to revert back to AsusWrt firmware, if you need to start over.

The AsusWrt firmware is here. Click on 'More' to reveal the 'ASUS Firmware Restoration version' under 'Drivers & Utilities'.

I successfully re-flased with the "sysupgrade" image you pointed out using luci. I have to say, I don't remember if I un-checked the "keep settings" :sweat_smile: What is the worst that can happen?

After the re-flash, my modem is recognized as a RT-AC85P, which is awesome.

My 2 wirelesss cards are still recognized as MT7615E (instead of MT7615N, based on the specs. Does anyone know of more appropriate drivers?

I see the 2 wifi cards are working at 2GHz and 5GHz and tested them also. I will provide feedback on the speeds later.

Finally, I hope I won't encounter any 5GHz issues as others have mentioned! For now it looks like it is working.

Everyone, Thanks again!

fwiw, you could go into Backup/Flash firmware menu option and click 'Reset' to clear all openwrt settings back to defaults if in doubt?

Does 5 GHz wireless setup menu in LuCI offer 'AC' and '80 MHz' ?


(I don't own a RT-AC65/85P btw)

Yes it offers AC and 80HMhz, as well as 160 MHz. Until now it seems it is working well :smiley:

Please mark as solved if firmware successfully installed and 802.11ac wifi appears to be working.

Regarding MT7615E vs MT7615N. I think there is just the one openwrt driver MT7615E for all routers which use MT7615 family of chipsets. Someone will correct me if I'm wrong.

1 Like

@bill888 and @tmomas your support is greatly appreciated!

I confirm everything is working well (for now). Marked as resolved.

Happy to hear if someone knows a better/more applicable driver/firmware for my MT7615N network card .

FYI, some first speed tests from run with Passmark Advance Network test from my laptop (win 10) wifi (connected over 5GHz AC Nominal T866/R866 Mbps) to a desktop (win 10) connected over 1Gbps ethernet via the ASUS/Openwrt router:

IPv4/TCP | Send | Avg: 524 Mbps | Max: 562 Mbps
IPv4/TCP | Receive | Avg: 517 Mbps | Max: 614 Mbps

IPv4/UDP | Send | Avg: 566 Mbps | Max: 617 Mbps
IPv4/UDP | Receive | Avg: [didn't work] | Max: [didn't work]

Should I be happy with these?
Btw the UDP receive test was not successful, but I suspect its the passmark, all packets were dropped.. I will check later with another piece of software if I can.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.