Install openwrt with dead unifi-ac-mesh

When you say dead, how dead? Do the blue and/or white LEDs on the side blink? Does the link light on your PC come on when you plug in the Ethernet cable?

A default install of OpenWrt will have the default IP configured on the Ethernet port, with a DHCP server also running.

no i dont have ttl seral cable yes it turn on when i connect it with poe

yes the lede blink and link ligh come . they dead i loss power on all theme with install . no request from and i dont get ip from dhcp server . i insert it in recovery mode to tftp it with firmware again but i failed with theme

Have you tried a reset (following the procedure in the qsg)?

Were they working or broken when you got them?

If the LED on the side blinks fast, then blinks slow, then stays on, that's a normal OpenWrt boot.

The bootloader TFTP recovery mode (accessed by booting up with the reset button held down) only works with signed Ubiquiti firmware. It will not accept OpenWrt directly. You would recover to stock then install OpenWrt again.

yes i tftp it to stock but the problem the tftp dont work no request from device .
as shown on

yes i tried to reset it to stock but its failed and they work when i got theme

The device is a server. It does not make a request it waits for you to use a client on your PC to put the firmware to it. The PC must be set with a static IP. The IP of the AP will be, so use any other IP in that subnet. The recovery mode does not answer pings or DHCP requests.

Windows 10 has a built-in simple CLI TFTP client that works almost exactly like the one in Linux, but it must be enabled by going to Windows Features in the Control Panel.

is there any other way to re-install them without tftp . all other device work with tftp except these device

If they were working when you first got them, did you do the same thing (with the same resulting situation) to all of them? Or did you try different things on each? I ask because it will help us understand what has been done to get them into this state (and hopefully to help you get them working again).

What exactly are the LEDs doing (what color(s) do you see, are they solid or blinking, etc.) -- the blink pattern can tell a fair amount about what is happening.

Can you describe the exact steps that you took to get to this non-working state?

When you tried the standard factory reset, did you try to ping the device at And as @mk24 mentioned, did you set your computer's ethernet port to be manually configured on the same network -- for example, setting an IP of, subnet mask (btw, I'd recommend that you connect directly to the AP, only connecting through the PoE injector or a PoE switch (that switch should have nothing else connected other than your PC and the AP) .

Also, as an aside -- why are you installing OpenWrt? I'm asking because I'd like to make sure we're guiding you in the right direction. Given that you have 8 of these devices, if you are using them really just to setup a mesh network (and not for other functinos), you may actually be better off using the standard Unifi firmware because it will actually make management of all devices easier. Don't get me wrong -- I love OpenWrt, but this might be a case of 'the right tool for the job.'

these device i work with theme in first time i install openwrt so i have some problem with install some of theme i loss power when i install openwrt other device i break theme when i try to upgrade theme , but after this Experiments i learn more about openwrt . yes i try to ping to with same network and my pc connect directly to it.
about why i install openwrt
in first time i use unifi with there stock firmware for more than 1 year its nice but its not what want : i explain what i do with my small isp and its answer why i use openwrt
1 - my isp work with 802.1X (wpa-enterprise) so each client in public area they get user and pass to connect with my network (more secure than open wifi ) with freeradius access-period policy after that they redirect to login page (captive-portal with coovachilli ) they insert there information and connect and they get 1H free access to internet after that if they need they should connect with support or one of our office to buy more time .
2 - some shops need to connect but the wifi signal poor so i use tplink router with openwrt this tplink router connect to main aps with second hide ssid which is in wds mod and repeat first ssid (802.1X ssid )
3 - all device work with (custom image build openwrt ) because in some place i need pppoe or pptp .
4 - openwrt from my test some unifi-ac-mesh total client connect on it in same time is 80 client with (1MB up and 1MB down ) and its work fine without any problem .
5 - i use zabbix-agent with my aps and router
6 - openwrt is very flexible for my work i install device and connect it to my isp data center and its work without down some device they work about 120 days without any problem .
7 - now i have 60 unifi ac mesh and over 30 router with wds mode (tplink arher c50 v4 )

so for this purpose i use openwrt and i cant do all this with unifi or any other brand
thank you for your time and I apologize for my bad English language

so i need more device about 10 unifi ac mesh so i see these broken device and i try with theme in past but failed so i create this topic

Ok... it is clear that you have good reasons for using OpenWrt -- just wanted to check.

When you mention upgrading the theme, are you referring to the LuCI-theme (i.e. the visual look of the LuCI web interface)? or are you talking about a version upgrade such as from 18.06 > 19.07 or 19.07.1 > 19.07.2 using sysupgrade or the LuCI upgrade firmware feature? Or did you use some other method of upgrading stuff on your devices?

What was running on the devices when they were last working? and what exact steps did you use to attempt to upgrade? did you get any error messages or other indications that it wasn't working? And do you have a backup of the configuration from when they were working?

sorry , i talking about a version upgrade from 18.06 stable to snapshot as I remember i use sysupgrade , last running firmware before they dead is openwrt , i dont have backup as i say they experiments .

Did you use the factory or upgrade image?

Also, what exactly do the leds do when you power on the device? What colors/blink patterns do you see?

I think its factory not upgrade
When power device its blink white led and when I press the reset and turn it its insert in recovery mode with white/blue blink .

If you were already running OpenWrt, you should have used the upgrade image, not the factory one. That may have caused it to go into this strange state. [EDIT: as @mk24 points out later, there is no factory image for these device.] The white/blue blink is potentially a good sign.

You liked to the TFTP recovery page from UI -- did you follow those directions exactly? As @mk24 said, you must 'put' (send) the file to the device from your computer, and it will only work with the official UI firmware, so make sure you have downloaded that firmware from the UI website.

There is no "factory" OpenWrt for these-- the "sysupgrade" build is used to install OpenWrt from a running factory install, with the mtd method.

I always installed to kernel0 and erase kernel1 and make sure the bs bit is zero, as described in the device page.

They work well with 19.07.2. Snapshot builds are not suited to commercial deployment. If you really need something that is not in the release build, make an own-build from a consistent starting point.

1 Like

yes i build my release before +1 year and its work perfectly , but the problem with this old build device which i install openwrt in it without any Experience in past and really i dont remember what happen to loss theme but i think some of theme loss power when they mtd openwrt

can we Bring back theme to life
and as you say @mk24

If the LED on the side blinks fast, then blinks slow that's a normal OpenWrt boot

and this i see it in some of theme so the openwrt is install on it but not work (broken instillation )
thank you for your time dear @mk24

could you help me about this?Need a copy content of full-flash about uap-ac-m