Install OpenWrt on Wavlink Quantum DAX via TTL, where am I wrong?

Hi everybody,
I'm new to this forum but not entirely new to OpenWRT, even though it's my first time attempting an install from TTL.

Yesterday I bought two Wavlink Quantum DAX for 25 euros each (new, from Amazon).
Unaware that there was a remote possibility of installing OpenWRT.
I then found this post:

Reading that you could overwrite the Wavlink firmware with the latest openwrt via the TTL port, then bought both the USB to TTL and Dupont cables.

I made sure, according to the manufacturer's provisions, that the USB to TTL worked correctly, and it is (short between TX and RX).

I disassembled everything, taking out both boards of which it is composed (connected by a kind of PciE), reassembling without houses on the table, turning them to show the 4 pin of the TLL and started the test.

I use Dupont cables by inserting them in the holes on the board after using the tester and checking that they come out 3.3V, following the correct arrangement of the cables (which is printed directly on the board) of the TX RX and GND.

The problem is that I can't access the Router's serial, the router starts but I don't see anything in the shell (I've tried both Putty and Tera Term), I don't know if I'm wrong with the timing.

If I insert the converter before the router Power on, it does not complete the startup, if I insert it after 5 seconds (the time the lan starts flashing) I get nothing, even after 30 seconds as written on the OpenWrt guide on TTL connections, once out of many attempts I got (strangely) that the router started but with DHCP disabled (192.168.10.1 manually set), but on the shell I didn't see anything anyway.

The converter has two check LEDs for traffic on the TX and RX channels, the RX connector always produces a faint check light (different from the brighter that appears when I short to check correct operation) while that of TX makes a faint light every time I press a key in the shell, except for a few seconds during the final stages of boot I see the TX flash several times (brighter) without getting anything in the terminal.

As settings reading in that post I'm trying with these:
115200 8n1 flow off
(I also tried 9600, with no results other than those described above)
I tried setting the converter both with COM4 (the one selected by default when installing the driver) and COM1 or COM3 without changing anything (even i try with other USB port).
The router works correctly (except if I connect the serial before turning it on, as I said above).

I don't want to give up, but since it's my first time using TTL, adapter and cables I preferred to ask for help here on the forum.
Besides they look like great devices, poorly maintained, and OpenWRT is a great solution.

I ask for your help to understand where I am wrong.
Thanks
Matteo

1 Like

@matetod

Have you got anything else to test the TTL adaptor and cables with?

Which firmware version are you running on each Dax, I installed openwrt after installing 31.0.0.17 as attached in the linked thread.

I would try swapping the RX and TX around. You should be getting something over the ports, mine are hooked into each port.

I still have a second Dax to flash, I can document the process with my cp2102 TTL adaptor if it helps?

Can you share a photo of your connections to the uart?

Make sure the 3.3v connection is not connected

Sure give me some min, i take a picture and send this, VCC is not connected

In theory I would have a Raspberry Pi2, another device that I have never tried to access in TTL.
I try to swap TX and RX, I was holding them in place with a small piece of tape pushing them to one side.

If you have the patience, it would be very useful (even post it in the Wiki even more) document the process.

P.S:
No, i don't update the router i think it had 31.0.0.14, another try to do.

P.S.S:
YES! Swap TX and RX works!
Now is the turn of Tftp server :smiley:
But now i don't know if update to 31.0.0.17 or flash directly OpenWRT 21.03

P.S.S.S:
Flashed!
Now it works, once the TTL got underway everything worked great.
I agree with D35P4C1T0 who in the other post said that Wi-Fi performance has deteriorated.
I went from (the farthest point from home) a good 170/200 to an unstable 40/50, in the same position as the router and the phone (a Samsung S21), I saw you were talking about adding proprietary drivers ("You can add the proprietary driver to the current release ") which packages are you talking about?
Of course I have installed the 22.03.

Thanks thanks thanks again

I don't know if it is the case to open another thread, in practice on the 5Ghz Wi-Fi I have what seem to be power problems.
Yesterday after the firmware flash I changed the basic settings, I changed the names and mounted it and it worked, this morning I realized that even at 1 m from the router I have -86 dBm and consequently also something like 28Mbits on 5Ghz.
I tried to change the settings, but nothing, I tried to do a soft reset of the settings, nothing, I also tried to flash openwrt again from its update screen, nothing, to the default settings the 5Ghz network does not work, not even changing the settings such as Band and power (which remains fixed at 31 dBm), and as if I had no output power, the 2.4 works smoothly.

There's been issues with the broadcom implementation for a few years, post above has links to the proprietary brcmfmac4366-pcie.bin wireless driver.

gr0 was disabled at kernel level with 22.03rc6:
https://git.openwrt.org/?p=openwrt/openwrt.git;a=commitdiff;h=5359a8ca382f473e2f671f6ed6f22e9d811c80cf

lastly irqbalance is recommended, and there's a tweaked regdb somewhere

I try to apply these tips and let you know,
but I don't understand why even at 10cm from the router I get a huge dBm of something like 70/80 if not more, of course if I move away it takes 3/4 meters in a free field to completely lose the signal

Have you securely reattached the antenna

Sorry i wrote the message and i didn't send it:

You are great, now it works and even with a higher signal than the original.
I'm afraid to change the 5Ghz channel that is on 36 :rofl:
I retrieved the 2018 broadcom driver bin, I read that there was the 2020 one that added support to the 160mhz band, but I can't find it anywhere (even if it doesn't seem essential to me, since, perhaps, I only have the laptop with 160mhz support)

Thanks again

P.S:
I found it, the entry 160 Mhz appeared but ofc it don't work (i read it in the post that you link that say don't work) but all still work right (Tryed on Samsung S21, an iPhone X and a laptop with Intel Ax201 a HP 830 G8 from work, and don't work).
If can be userfull:

I try that one called: brcmfmac4366c-pcie.bin_ac88_3
I don't know if exist some other version than this.

1 Like