Install OpenWrt on Linksys EA6500V2 that has v.1.1.42 already installed on it

So I've searched and searched for a way to install OpenWRT on to a Linksys EA6500 v2 router. I could not find a thing on how to do it. I've found possible ways but none worked that I have tried.

I went old school. I remember that I had once installed successfully DD-WRT on the same router, prior to the Linksys firmware being altered to only accept Digitally signed firmware. The digitally signed firmware packages started after v1.1.40.166281(from some of the info I have found in my searches). I searched DD-WRT for the method I used to upload the DD firmware to the router. I used that method to revert the stock firmware to a version prior to the V1.1.40.166281( I used V I then flashed the OpenWRT firmware to the router using the web interface.

For how I did this:
I tried doing the method using windows but I wasn't successful with that way.

I have an OLD Macbook that still works and used the Mac OS X method to install the firmware using TFTP.

Set your network adapter to be a static Address
Open 2 instances of terminal

In one terminal instance ping (router doesn't need to be on)

In second terminal instance type the following:
change directory to where your firmware file is, otherwise you'll get error when you try to push it to the router (I found this easier as I'm not a full on linux user yet and don't know all the syntax to get to a file on a external drive)
rexmt 1
timeout 60
put <firmwarefile.ext> (do not hit enter just yet)
Plug in router, and when you start seeing pings returned from the router hit enter to upload the firmware to the router.

If all went well you have an older stock firmware on the router. I have tried uploading the OpenWRT firmware but I think it bricked the router as there was no reply from router on pings, even after a reboot.

Hopefully for those wanting to Change over to OpenWRT this helps some.

This could be added to the OpenWRT EA6500 v2 page for how to install OpenWRT since its not got much information there.

Would you by chance know where to look for a Firmware version that's compatible? As far as i can tell the Official Linksys site does not offer older versions. Quick google searches turn up nothing useful as far as i can tell. Will continue to scower the internet now that i know what versions will work. Thank you for the guide and the information.

EDIT: I have found the proper image.
EDIT2: Attempted to flash via tftp from Kali Linux with 2 failed attempts. Also attempted to flash older FW img from Web-UI with out success.
After the second attempt via tftp i got a security certificate warning when browsing to the page but the version number in the Web Panel did not change. Specific version is

Linksys EA6500 V1.1.40.160989

Here is the Link to the firmware I used.

I'm not sure if the commands I used with MAC OSX coincide with Kali Linux commands. But if your catching the TFTP client on the EA6500 when the Ping is hitting ttl=100 (during the first few seconds after powerup. Thats when you need to send the "put" command above

1 Like

Uploading img during the boot sequence works just fine (at TTL=100 as described), however firmware version in Web-UI remains on v1.1.42. Attempted to set IP address to static on same default subnet to eliminate time spent on DHCP handshakes.TFTP application provides sent/ACK messages, however image fails to install. Verified tftp command supports same options and intended use. Attempted to load provided file into Web-UI with "Invalid firmware file message". I'm assuming this is due to the lack of a digital signature. Is it possible to provide the file with a Digital signature to fake out the router? Just for the sake of scientific process do you by chance happen to have the sha256sum of the file you uploaded during your initial flash?

c149ea2ac030b0b1eac23021957ac6d0b2cd22588b4f2e18bbeed69a55f2a530 FW_EA6500v2_1.1.40.160989_prod.img

I double checked the image you linked and the the one i found (not on the Linksys page you linked) and both match. i think its safe to assume the original file you had would also match. This particular problem is becoming a head scratcher. do you think a full 30-30-30 reset of the device would help in anyway? i know over on the DD-WRT site (Peacock Thread in refrence to 30-30-30 resets on EA Routers.)

..... DO NOT DO THIS PROCESS WITH AN EA SERIES LINKSYS ROUTER. They have a small CFE Nvram storage that holds important information, and this cannot be erased! Use the factory reset option.

I have personally done this with many other routers for installing OpenWRT and have not experienced any issues before...

EDIT: please note i have NOT performed a 30-30-30 on this device previously.

Yes, trying to install the previous version of firmware with a v1.1.42 will result in the "Invalid Firmware file" message, unless its the v1.1.40.166281, or before. Its possible that if we knew what the digital sig was for the files we could fool it to work, but I think that would require trying to figure out where they put that sig in a newer version firmware and then importing it to the older file, without corrupting it in the process.

I've done the 30-30-30 on my EA6500 before, though I don't know if I wiped out the Nvram that they describe on the DD-Wrt site. But I may have totally fudged on doing it saving the Nvram.

As for the SHA256sum of the file I have used its as follows


I'm thinking that the EA6500 v2 has a secondary firmware, if I remember right, in case of a failed update. I'm wondering if the upload you are doing is somehow failing. This is the only think I can think of atm considering you keep seeing the newer firmware version.

I've done this a few times when it seemed the router wasn't working for me. Press and hold the Reset button for 15sec and unplug and release reset, when you see the Linksys Logo start blinking. Plug it back in and install, through TFTP the firmware.

I'm currently having issues with the EA6500 when I put the latest Snapshot on it. I try to update packages and end up with "filesystem is read only", which means the memory is full....though unless its having installed OpenWrt multiple times in the last few days, it shouldn't be that way.

I'm not sure why you want to install openwrt on such a old router. It may lost NVRAM data due to 32k bug when you try to upgrade cfe or switch to another rom. Now I'm using 6500v2 as AP using asus merlin rom, it's stable.

Yes, it is possible. I recently had the same problem with signed firmwares. I looked for a way to use the usb to ttl (Universal asynchronous receiver/transmitter - UART). In my case, it worked!
Today, on my EA6400 I can install any firmware on it, whether openwrt or DD-WRT.

The way I got the old LinkSys firmware on the router from Windows 10...

I had DD-WRT installed on my EA-6500 V2 and I unwisely installed the current version of LinkSys firmware ( which prevented me from upgrading to firmware that I want or downgrading to old LinkSys firwmare.

I finally got installed (downloaded from one of the posts above). I'll repeat some of the instructions from the original post.

  1. Ensure you have TFTP enabled in Windows. Type tftp /? in a command prompt. If command prompt doesn't recognize that command, use "Turn Windows features on or off" to enable TFTP Client.
  2. Open a command prompt and navigate/CD to the directory where you have the LinkSys firmware you want to flash.
  3. Type in the following command but don't send it yet. I think LinkSys will only accept the TFTP within a short window of time during booting up.
    tftp -i put FW_EA6500v2_1.1.40.160989_prod.img
  4. Open a second command prompt window and type in the following command but don't send it yet.
  5. Power up the router.
  6. Start pinging by sending the ping command in the SECOND terminal window. As soon as you get a reply, send the TFTP command in the FIRST terminal window.
  7. Be patient while the file is sent. You won't know for a while whether the push succeeds or fails. It failed on my first try because I missed the startup window. If it fails you will get Connect request failed. If it succeeds, you will get Transfer successful: 15061248 bytes in 69 second(s), 218278 bytes/s or similar.
  8. After successful firmware flash, the router will reboot itself automatically and when its light stops flashing, you can access its web interface (use default password 'admin' to access it).
  9. On my Connectivity > Basic page, it now shows "Current Version:"
  10. Using the "Manual" button, I uploaded openwrt-22.03.2-bcm53xx-generic-linksys_ea6500-v2-squashfs.trx, and eventually, the router gave me its "Router Reboot" message instead of the "Invalid firmware" message.
  11. The router will happily continue to say "Waiting" even after the router has rebooted into OpenWRT, so you might as well just renavigate to
  12. Success!
    (Of course, wireless is disabled on this router with OpenWRT due to having Broadcom guts).
1 Like

I was flashed 'FW_EA6500v2_1.1.40.160989_prod.img',but password is not 'admin'. i cann't login.

Thank you sir. This post helped me in getting a older firmware on my EA6500V2.

Has anyone had luck having OpenWRT persist on this device? I can flash it either through the stock firmware web UI or tftp but OpenWRT does not survive more than one reboot typically.