Install OpenWrt on Check Point L-50 issue

I install Openwrt in Check Point L-50 router according below.
after install, I can access via web, found 'refreshing' button on the right.

the router hang, once reboot the router, need use "kwboot -B 115200 /dev/ttyUSB0 -b u-boot.kwb -p -t" to boot the router.
I run "cat /proc/mtd" get below, I think the uboot and image write have issue.
how to fix this issue? thanks.

root@OpenWrt:/# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 000c0000 00020000 "u-boot"
mtd1: 00040000 00020000 "bootldr-env"
mtd2: 07900000 00020000 "ubi"
mtd3: 00800000 00020000 "kernel-2"
mtd4: 07100000 00020000 "rootfs-2"
mtd5: 07900000 00020000 "default_sw"
mtd6: 01800000 00020000 "logs"
mtd7: 00100000 00020000 "preset_cfg"
mtd8: 00100000 00020000 "adsl"
mtd9: 07a00000 00020000 "storage"

Did you get all the way through step 6? The install is not permanent until you flash the sysupgrade image. All the other steps are loading images to RAM, which will only run once until rebooted.

1 Like
  • Those 2 shouldn't be writable
  • The information you posted didn't provide much infomration
  • Lastly, given you managed to install the web GUI on a Snapshot image, I don't think you have any write problems. Are you experiencing an issue?


I have done step 6, I run "cat /proc/mtd" after step 6, get the result is different with image author listed.
I have tried upgrade the image via web GUI, upload image and upgrade image seems normal, but after upgrade and reboot router, the router is hang.

It could be. Kirkwood is unbrickable architecture.

This is unofficial 19.07 image from This way it have luci.

Two questions:

  1. Did You overwrite stock uboot? (step four)
  2. Did You make all steps?
  3. Please paste bootlog.
1 Like

I repeat from step 2 to step 6 three times, the last times, router working normal.
the 1st and 2nd time, I see display "U-Boot" and one line garbled code via console, it stopped. I forget to keep the screenshot.

thanks for your reply.

@mk24 @lleachii thanks


I am also facing the problem described above: "garbled code via console" when running kwboot using u-boot.kwb from

At this point I was not too sure in what state the L-50 needs to be when running the kwboot command. Should it be up and running? should it be paused on the menu obtained when pressing Ctlr-C at boot time?

Anyway, I was also wondering if the L-50 will become "easy" to use with OpenWrt as other routers such that it will only be a matter of login in the admin console and upgrade the firmware to OpenWrt.

Or will it still be using the various lower level instructions posted on the initial git submit request.

Thank you for the feedback. Appreciate the help with this router.

Patrice R.

Hello All,

After some more reading and investigations I was able to clarify the install operations on my L-50... Initially I admit that I was unfamiliar with the tools and operations but now was able to fully install the snapshot version of OpenWrt on this device.

  1. "garbled code via console" was it seems purely my fault. While running kwboot I was also running "minicom" to access the serial port and this was the problem... So when running kwboot, don't do anything else to avoid interference with kwboot on the serial port.

  2. when to run kwboot? I admit not yet sure about when is the right time to do so but I was lucky enough to be able to reboot and run kwboot at the right time to be able to get the process going

  3. When should I run the commands mentioned in the device page (such as "usb start")? These need to be typed once the kwboot command give you access to the "console"... This is happening because of the "-t" option AFAIK

So now I am "all" set and running OpenWrt... Including the "wireless" menu I was surprised to see appearing later on in the process (magic?).

What seems to be missing though is the "Switch" menu but this may be related to the installation of the snapshot version.

Thank you again for the support.

Patrice R.

Hi patrog

This problem that you met has troubled me for a long time, so I share more detail info with you.

1st, backup mac addresses is more important,if you have backup it please ignore.
use 'dd if=/dev/mtd2 of=/tmp/bootldr-env.bin' to backup
use 'hexdump -C /tmp/bootldr-env.bin', you can find all mac addresses that need backup.

2nd, you need get compatible version kwboot. first time I get a version run ARM CPU, cannot run on my CentOS 8. you can refer below link to compile it yourself, or leave your email address, I will send to you.

want run kwboot need use 'chmod +x kwboot' add execute privileges.
[root@localhost tmp]# chmod +x kwboot

3rd, do not run minicom, power off the router.
power on the router after run below command, you will see like below.

[root@localhost tmp]# ./kwboot -B 115200 /dev/ttyUSB0 -b u-boot.kwb -p -t
Sending boot message. Please reboot the target.../
Sending boot image...
  0 % [......................................................................]
  1 % [......................................................................]
  2 % [......................................................................]
  4 % [......................................................................]
Hit any key to stop autoboot:  0
ubi0: attaching mtd3
ubi0: scanning is finished
ubi0 error: ubi_read_volume_table: the layout volume was not found
ubi0 error: ubi_attach_mtd_dev: failed to attach mtd3, error -22
UBI error: cannot attach mtd3
UBI error: cannot initialize UBI, error -22
UBI init error 22
Please check, if the correct MTD partition is used (size big enough?)
Error, no UBI device selected!
Wrong Image Format for bootm command
ERROR: can't get kernel image!

4th, input below for set mac address, replace XX to your backup mac address.
=> setenv ethaddr XX:XX:XX:XX:XX:XX
=> setenv eth1addr XX:XX:XX:XX:XX:XX
=> setenv lan1_mac_addr XX:XX:XX:XX:XX:XX
=> setenv lan2_mac_addr XX:XX:XX:XX:XX:XX
=> setenv lan3_mac_addr XX:XX:XX:XX:XX:XX
=> setenv lan4_mac_addr XX:XX:XX:XX:XX:XX
=> setenv lan5_mac_addr XX:XX:XX:XX:XX:XX
=> setenv lan6_mac_addr XX:XX:XX:XX:XX:XX
=> setenv lan7_mac_addr XX:XX:XX:XX:XX:XX
=> setenv lan8_mac_addr XX:XX:XX:XX:XX:XX
=> setenv dmz_mac_addr XX:XX:XX:XX:XX:XX
=> setenv dls_mac_addr XX:XX:XX:XX:XX:XX

5th, below is update u-boot and uImage, I use USB save the u-boot and uImage files.
=> mw 0x0800000 0xffff 0x100000
=> nand erase 0x0 100000

NAND erase: device 0 offset 0x0, size 0x100000
Erasing at 0xe0000 -- 100% complete.
=> usb start
starting USB...
USB0:   USB EHCI 1.00
scanning bus 0 for devices... 3 USB Device(s) found
       scanning usb for storage devices... 1 Storage Device(s) found
=> fatload usb 0 0x0800000 u-boot.kwb
643072 bytes read in 71 ms (8.6 MiB/s)
=> nand write 0x0800000 0x0 0x100000

NAND write: device 0 offset 0x0, size 0x100000
 1048576 bytes written: OK
=> saveenv
Saving Environment to NAND... Erasing NAND...
Erasing at 0xc0000 -- 100% complete.
Writing to NAND... OK
=> fatload usb 0 0x0800000 uImage
6271326 bytes read in 610 ms (9.8 MiB/s)
=> bootm 0x800000
## Booting kernel from Legacy Image at 00800000 ...
   Image Name:   ARM OpenWrt Linux-4.14.180
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    6271262 Bytes = 6 MiB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... OK
mdio_register: non unique device name 'ethernet-controller@72000'
   Loading Kernel Image

Starting kernel ...
[   25.943424] mv88e6085 f1072004.mdio-bus-mii:10 lan7: Link is Down
[   25.964388] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   28.157914] mv88e6085 f1072004.mdio-bus-mii:11 lan8: Link is Up - 1Gbps/Full - flow control off
[   28.173224] br-lan: port 8(lan8) entered blocking state
[   28.178487] br-lan: port 8(lan8) entered forwarding state
[   28.205542] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready

press Enter key
change the root password and run sysupgrade

BusyBox v1.30.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 |                                                                           |
 | OpenWrt 19.07-SNAPSHOT, r11104-e752fc1ff9                                 |
 |                                                                           |
 | Build time: 2020-06-06 19:04 CEST                                         |
 | Cezary Jackiewicz (obsy),                               |
 |                                                                           |
 | Machine: Check Point L-50                                                 |
 | Uptime: 0d, 00:01:37                                                      |
 | Load: 0.93 0.37 0.13                                                      |
 | Flash:                                                                    |
 | Memory: total: 501.1MB, free: 487.0MB, used: 2%                           |
 | Leases: 0                                                                 |

 | lan: static,                                                  |
 | wan: dhcp, ?                                                              |
 | wan6: dhcpv6, ?                                                           |
 === WARNING! ================================================================
 There is no root password defined on this device!
 Use the "passwd" command to set up a new password
 in order to prevent unauthorized SSH logins.
root@OpenWrt:/# passwd
Changing password for root
New password:
Retype password:
passwd: password for root changed by root
root@OpenWrt:/# sysupgrade /tmp/luci-19.07-snapshot-r11104-e752fc1ff9-kirkwood-c
Cannot save config while running from ramdisk.
Commencing upgrade. Closing all shell sessions.
Watchdog handover: fd=3
- watchdog -

next, the router will reboot, after reboot, install is finished.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.