Install OpenWrt firmware in qca9531

Hello Support,
I have a router that was manufactured by HONGKONG YUNLINK TECHNOLOGY LIMITED with a custom brand name. I tried to upgrade it with openwrt firmware as the router showed bug in various features such as mac filtering. But instead i bricked the router and can't get back to the stock firmware. I contacted the hardware manufacturer but they have no support for firmwares. The gui i used looked exactly like the openwrt configuration page, i wish i had screenshot to show. I have gathered some information about the hardware which was given by the hardware manufacturer(said can't give other info):
Router Name: Kloudspot
Router Model: KSPOT X200
Firmware Version : Kloudspot BB 4.0
Kernel Version: 3.10.44
MAC ADDRESS: 78:D3:8D:BD:86:D8
Chipset: QCA9531
Flash Memory: 16MB
RAM : 64MB
As, I am unable to retrieve the initial firmware that came with the router as i contacted everyone related to the product, all said its discontinued and don't have the backup firmware. All the ethernet ports are in bridged connection, i can switch to any port for accessing the internet as in switch. I have figured out a way to install firmware file through tftp server and the default ip address of the router is and is looking for ip address I have tried all other firmware that might be compatable with qca9531 chipset but none of them work or maybe i missed out something. So, is there any way i can install openwrt firmware that might be compatible with the above specifications? I am just a beginner to this.

not without further work, it's not a supported device.

can i install openwrt in unsupported devices? coz the firmware that was used in it before it got bricked was a customized version of openwrt. isn't there any solution to make the router work?

you can install it, but there's not guarantee it will work, might even soft or hard brick it.

You can easily install this in your described hardware.
See this Routers with QCA9531
You can install one of them in this router, for example you can try TL-WR810N or other TP-Link models but first you need a compatible bootloader.
You can try this Breed-QCA953X
I have recently installed Openwrt on unsupported device with QCA9533 Read This Tutorial
So it is possible to install openwrt if your device have supported CPU, at least 32MB Ram & minimum 8MB of Flash, However if you want to install additional packages later 32MB Ram may be insufficient.