Install OpenWrt 18.06.2 on ubiquiti edgerouter x

Hello all,
Here is a small summary on how to install the latest Openwrt on the Edgerouter x
I read this topic from dingbatca

  1. Clone the GIT repository

git clone -b openwrt-18.06

  1. run the updates
    cd openwrt
    ./scripts/feeds update -a
    ./scripts/feeds install -a
  2. run the menu to configure the target image
    make menuconfig
    Target system : MediaTek Ralink MIPS
    Subtarget (MT7621 based boards)
    Target Profile (Ubiquiti EdgeRouter X)
    Target images : Ramdisk with lzma compression

These parameters aren't enough because the image generated is too big
=> you won't see any factory images after the compilation !
We need to save space, I propose to remove IPv6.
Go to "Global build settings" and remove "Enable IPv6 support in packages"
Exit and save the configuration, then you can run the compilation
make -j8 (you can increase this value if you have more CPU cores)

When the compilation is done, you should find your image in bin/targets/ramips/mt7621/

Now you can copy this image to the router
scp openwrt-ramips-mt7621-ubnt-erx-initramfs-factory.tar ubnt@
( is the default IP address, ubnt is the default password)

Connect on the router and update the image

ssh ubnt@
cd /tmp
add system image /tmp/openwrt-ramips-mt7621-ubnt-erx-initramfs-factory.tar

Switch to the official image (with IPv6 support now)

ssh root@
cd /tmp
sysupgrade /tmp/openwrt-18.06.2-ramips-mt7621-ubnt-erx-squashfs-sysupgrade.tar

and that's all !

It isn't necessary to build yourself. I used the pre-built initramfs image on the download server.

I didn't try it because I believed the "add system" command expects a tarball file.
Somebody asks if he can use the kernel.bin file but he didn't get any answers.
I was afraid to brick it, that's why I used the tradition way :slight_smile:
Thank you for your feedback, it can save hours of compilation !

I have one of these devices and intended to follow the same instructions to install openwrt.

I think I found the output was openwrt-ramips-mt7621-ubnt-erx-initramfs-kernel.bin not tar.
and openwrt-ramips-mt7621-ubnt-erx-squashfs-sysupgrade.tar.

Where did I go wrong in menu config?
I believe I followed all your instructions.

Did you remove the ipv6 support ?
If you don't see the tar file that means the image is too big

I didn’t as I compiled before reading your instructions. So if I make it smaller it will be a tar not a bin. That sounds like the missing information. Thank you I’ll try again soon.

That's correct.

That's correct too.

Why do you think you need something else than those two files?

First you will flash the initramfs into a kernel partition. The initramfs is a fully-functioning OpenWrt except that it does not have a flash file system-- all of its files are in RAM-- thus it can't save any settings permanently. Boot up the initramfs and use it to flash the sysupgrade. This will create the flash file system in OpenWrt format so it can be used. The sysupgrade also replaces the initramfs kernel with a regular kernel that mounts the flash file system.

The Edgerouter-X has a large flash chip, it is not necessary to worry about removing packages to make OpenWrt fit. Use the two official pre-built 18.06.2 files on the download server as they are.

OK, followed the instructions here and have successfully replaced edgeos with openwrt on my Ubiquity edge router.

Things I noted that could be clearer in the instructions.

First, I did need to exclude the ipv6 packages to get the build process to deliver a tar file rather than a bin file.

Second, I had to change the physical port I had connected to after the first openwrt boot. I'm guessing the port I connected to on edgeos became the wanport on openwrt. So if I was using Port 0 on edge OS, I changed to Port 4 on openwrt and connected fine.

Third to get the official image, I needed to wget on an internet connected machine and scp to /tmp, as we did with the ipv6 less tar file.

But other than that these instructions were very clear and this was a very easy conversion.

I do have one issue though. I appear not to have uhttpd installed and so I do not have the web based configuration options. I can't make a browser connection and can't see uhttpd either running or installed with opkg. What did I do wrong?

I thought I needed something other than a .bin file, because the instructions here refer to a tar file.

I did not try the edgeos command
add system image filename.bin

Do you think it would have worked the same way as the tar file?
If so that would have saved me a step, but I thought the original poster might have recommended that if it is the case.

OK, so I think you are saying that the OPs instructions about excluding IPv6 packages is unnecessary because we do not need to make a smaller file.

My only issue with that is whether the edgeos command
% add system filename.tar
would also have worked with
% add system filename.bin

I would be nice to know because if it does these instructions could be further simplified and there would be no requirement to build an image (although that was a good learning experience)

I can see that if you added stuff to the initramfs image it would become too large for the kernel partition. Why would you do that though? The initramfs image only needs to do one thing, sysupgrade to the final image.

hi,im a newbie so i want to ask the image you suggest you just go to upgrade firmware and upload it?cause all these command lines look chinese to me

@vasilispr , welcome to the community!

Can you re-word your question?

Because my answer would be: "you install the upgrade firmware made for your device"...but that answer seems obvious.

Sorry for this but I haven't read so much in my life before,as I do after I got the edge router,so im dizzy.Also sorry for my bad English,isn't my native language.

The only thing I want to do is use a vpn to be able to change my ip to another country ip. For gaming purposes.I talked to many vpn sites like expressvpn or nordvpn but it seems they all need openwrt firmware.

So the next step was to flash openwrt to my router.Either is super hard or I'm missing something.I don't have knowledge about command promp or ssh (I think it's called that way).The only thing I've done was to get to openwrt site,find my router ,download a bin file and try to upgrade routers firmware.

I had a failed message so I tried to find a solution online.After hours of searching the only things I get is like build the firmware,something like That or numerous lines in command prompt or ssh.

So my question is That:is there an easy tutorial on how to flash openwrt to my router?Or is there any other way of doing my job with the current firmware?

As I said I just want to assign a foreigns country ip

Thanks in advance

You should consult the OEM's support/forums:

Thanks for the reply.Just a couple of questions.

1)At the start or the article he mentions "don't upgrade to v2 "the current firmware. Is that true?cause I've upgraded to v2 since I got the router.

2)All the procedure must be done while I have pc connected to eth0?My current set up is eth0 for wan and eth1 for lan

3)I have to use ssh or is it fine to use routers command line?

You were more than helpful already.Thanks