Install on ZyXEL Armour z2 With Luci?

Am I correct in thinking that the installation from the OEM firmware using the openwrt-ipq806x-zyxel_nbg6817-squashfs-factory.bin file gives an installation without the GUI? The file is about 24mb so this seems unlikely and I may be misreading earlier posts on the topic.
Help appreciated before I get into trouble.

Valid for all devices:
Snapshots -> no LuCI pre-installed, needs to be installed manually
Release (18.06.2) -> LuCI pre-installed, ready to go[Model*~]=6817

In short, yes - until 19.03.0 gets released, nbg6817 factory images are only available in snapshots (as the feature was only added after 18.06.0 was already released), which means they come without luci at the moment. You can either install luci on the snapshot at runtime or downgrade to 18.06.2 via sysupgrade, it's only the initial installation from OEM where you should really prefer the new factory images over the more arcane methods used before.

The factory images are padded to 4 MB + 20934k, because the vendor firmware won't accept flashing images smaller than this size.

Thanks for your reply. Is there a beginner tutorial on runtime installation of luci or for downgrade somewhere?

opkg update
opkg install luci

If you install LuCI, you can then:

  • Login
  • Browse to System > Backup Flash / Firmware
  • Flash the firmware for the version of your choice
  • Done

…and make sure not to keep settings, when downgrading.

1 Like

Installed snapshot/factory and opkg update and opkg install luci all seemed to execute without errors but opening in a browser gives

	/usr/lib/lua/luci/dispatcher.lua:587: Invalid controller file found
The file '/usr/lib/lua/luci/controller/opkg.lua' contains an invalid module line.
Please verify whether the module name is set to 'luci.controller.opkg' - It must correspond to the file path!
stack traceback:
[C]: in function 'assert'
/usr/lib/lua/luci/dispatcher.lua:587: in function 'createindex'
/usr/lib/lua/luci/dispatcher.lua:613: in function 'createtree'
/usr/lib/lua/luci/dispatcher.lua:279: in function 'dispatch'
/usr/lib/lua/luci/dispatcher.lua:144: in function </usr/lib/lua/luci/dispatcher.lua:143>

Is the simplest way to fix this to cli "sysupgrade" to 18.06.2?

Also I note that ssh into the ZyXEL firmare gives and openwrt screen!

Thanks for any help

just checked and opkg.lua is an empty file. What should it look like?

If you don't want to debug your issue (I'm using OpenWrt/ master, albeit self-built with luci included, from just a couple of days ago with luci just fine), yes - make sure to use sysupgrade -n /tmp/openwrt-18.06.2-ipq806x-zyxel_nbg6817-squashfs-sysupgrade.bin.

That works. Thanks for the help.

If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

You can also mark the reply that solved your problem:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.