Install on TP-LINK Archer A7 v5 (RU) 1.0.11 Build 20190810 rel.50990


I trying install OpenWrt on my router TP-LINK Archer A7 v5 (RU) with software version: 1.0.11 Build 20190810 rel.50990. I trying load openwrt-19.07.3-ath79-generic-tplink_archer-a7-v5-squashfs-factory.bin file from OEM GUI, but I got error "Invalid file type.".
Please specify how I can flash my router?
TFTP solution from this topic: TP-LINK Archer C7 v5 factory.bin won't load not working for me.

Or maybe any know how I can switch from DD-Wrt to Open-Wrt? I can flash DD-Wrt from OEM GUI.

Best regards!

From :

Please note however that this page will refuse to install firmware uploaded with a long filename. To bypass this limitation, download the relevant factory-flash BIN-file and then rename the file to firmware.bin before uploading.

Have you tried this out?

Same error(

Thakns for reply.

Try the TFTP installation method described on that page I linked above.

Are you sure you have the correct file? The wiki lists it as openwrt-19.07.3-ath79-generic-tplink_archer-c7-v5-squashfs-factory.bin

Why C7? I have A7 roter. Router page:

Not working TFTP method. I was try again and have same result.

Sorry. This is my mistake. I have A7 V5. I was changed topic name.

Sorry, I saw this

TFTP solution from this topic: TP-LINK Archer C7 v5 factory.bin won't load not working for me.

Not working TFTP method. I was try again and have same result.

I don't know what else to try, I'll let someone else help you.

The header of a stock or "factory" image has one or more country codes. If the expected country code is not found in the firmware presented, both TFTP and stock firmware GUI will refuse to flash it.

Using mtd directly from dd-wrt CLI could work. There is a high risk of bricking when using mtd directly. Make backups of the bootloader and ART partitions. Also make sure you can TFTP recover to RU stock. Then use dd-wrt to mtd the sysupgrade (not factory) OpenWrt to the firmware partition.

Thanks for reply. I have a full dump SPI flash with stock firmware.

I can change this country codes via hex editor or I need build new firmware?

DD-Wrt not have firmware partition. All what I see:

root@DD-WRT:~# cat /proc/mtd  
dev:    size   erasesize  name
mtd0: 00040000 00010000 "RedBoot"
mtd1: 00eb0000 00010000 "linux"
mtd2: 00c40000 00010000 "rootfs"
mtd3: 00150000 00010000 "ddwrt"
mtd4: 00010000 00010000 "nvram"
mtd5: 00010000 00010000 "board_config"
mtd6: 01000000 00010000 "fullflash"
mtd7: 00040000 00010000 "fullboot"
mtd8: 00010000 00010000 "uboot-env"

If write to linux partition from dd-wrt I got this error:

Unlocking linux ...
flash : Could not unlock MTD device: linux
linux: No such file or directory
Writing from firmware_openwrt.bin to linux ...  [w]
Warning unaligned data, we use manual padding to avoid errors. size was 32083!!!

Router rebooting and not boot to OS. Light only one power indicator. TFTP working but not flash any image.
I can restore routrer after this manipulation only flashing raw image on mem with programmer.

I builded image with and changed 5553 on 5255 in file staging_dir/host/bin/.tplink-safeloader.bin and flash my router from OEM GUI.

I found information in this topic: Support for TP-LINK Archer C7 v5 (RU)

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.