Install on RPI 4

I am unable to understand the proper installation process for open WRT for RPi 4,
can anyone send me the link and procedure for downloading GUI and GNU interfaces with RPi 4.
Much appreciated :slight_smile:

After it booted, ssh to it, and do

opkg update
opkg install luci

I installed it , but the ip addr 192.168.1.1 is not reachable , can you help with it?

reachable how, from where ?

connect it to a screen, you can do all config via the console.

The problem is i want to connect it via wifi, not ethernet and I am unable to do so
I saw this video (916) OpenWRT - Install LuCi on Snapshot Firmware - Raspberry Pi 4 - YouTube

and tried to connect via wifi and when I put 192.168.1.1 in search bar of my pc browser, it says can't reach this page

you can't connect via wifi, it's disabled by default.

connect it to a screen, you can do all config via the console.

yes I have connected it to a monitor, can u tell me how to config via console
and connect it to wifi and enable ssh

ideally, you should hook it up using ethernet port 1st, to make life easier, then fiddle with the wireless.

I dont have an ethernet cable, is there any other way to directly connect it to wifi

only wifi, and no ethernet cable, you're in for some serious hacking :wink:

I am not able to get the luci page i .e the web interface, I have connected it to wifi , but the web interface is not reachable. help me with this please

try reading this thread again.

How do I enable ssh in the command window if it is connected to wifi

on this thread they are using the web interface, and mine is not working

it's always on

but if you just C&Ped the whole setup from the link above, your wifi connection is now in the WAN zone, and you'll not be able to access it from outside.

but the web interface is still not working. what to do

same applies here, as for the ssh.

So how should I set it up again, please elaborate a bit
I will do it from the start , after flashing the image onto RPi and then connect it to a monitor, what should I do next if i dont have an ethernet cable?

skip the firewall section of the configuration, and use wireless.@wifi-iface[1].network='lan'

wifi-iface[1] should probably be wifi-iface[0], but you'll figure it out, using uci.

I didnt understand, shall I do the same as that youtube video except the firewall part?
then what about the wireless part?