Install luci-app-openvpn package

Hello everyone,

I am new to OpenWRT. I installed it on my Xiaomi AX3600.
I'm trying to install a VPN server by following this tutorial: https://openwrt.org/docs/guide-user/services/vpn/openvpn/client-luci
From the luci interface, it seems simpler to configure the VPN server than in command lines...

When I try to install the luci-app-openvpn package, I get this error:

Collected errors:

  • check_data_file_clashes: Package libnl-tiny2023-07-01 wants to install file /usr/lib/libnl-tiny.so
    But that file is already provided by package * libnl-tiny2023-04-02
  • opkg_install_cmd: Cannot install package luci-app-openvpn.

On the internet the problem seems to be quite well known and solved by reinstalling the Firmware. I tried version 23.05.0-rc2 and version 23.05.0-rc1 but I still have the same problem.

The opkg update command completes successfully.

I take this opportunity to ask a question, what is the difference between a version with "rc-x" and without?

Thank you in advance for your help.

try the sysupgrade image from https://firmware-selector.openwrt.org/?version=23.05.0-rc2&target=ipq807x%2Fgeneric&id=xiaomi_ax3600 add luci-app-openvpn (and luci) to the package list, it should figure out the dependencies for you.

Thank you so much. I got an "invalid file" error. I first switched to r2 then I switched to r2 with the extra packets and it worked.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.