Install EdgeRouter X issue

I'm hoping someone has a good answer for this one, but I've been trying to install OpenWrt all day on my EdgeRouter X to no avail. I've followed every doc/post I can find, I downloaded versions from 17 to 19 and even tried compiling my own.

I scp the image over and ssh to the EdgeRouter, run the 'add system image' command with that .bin file and every time it says:

Checking upgrade image...Upgrade image does not support the device. Upgrade failed.

Originally the router came with EdgeOS v1.9.7+hotfix.3.5013617.170830.0227, but then I downgraded to v1.7.0.4783374.150622.1533.

I'm at a loss at this point. Any help would be very much appreciated.

I used this German site posted by someone here. Worked like a charm.

1 Like

That worked like a charm! I used the initramfs file to update to openwrt (worked first time), then updated to the 18.06 version in step 2. Maybe the current boot loader for the ERX is actually looking for a tar file instead of a bin? :man_shrugging:

Can't thank you enough on this one, need to replace my home router ASAP and this was a huge pain.

1 Like

This is odd since in all the official builds the initramfs is a bin file not tar.

When I did the initial install on mine it bricked but that was likely because there's a bad block in my kernel2 flash partition, so I have to use only kernel1. I thought I had that worked around but it bricked again going from 18.06.4 to 19.07 rc1. This time the kernel boots OK but the ubifs was unusable. So I TFTP booted the initramfs from the bootloader then sysupgraded with it, and that worked perfectly except of course the config files were not saved.

Interesting that 19.07 sysupgrade is a bin and 18.06 is a tar. Is it always going to brick using 18.06 sysupgrade to 19.07.

More and more I just go directly to serial for an initial install rather than trying a case closed jailbreak from stock firmware. Except for the Ubiquiti stuff that's glued shut.

1 Like


Edgerouter X with stock firmware will not take anything with a .BIN. It must be a .TAR file.

ubnt@ubnt:/tmp$ add system image openwrt-ramips-mt7621-ubnt-erx-initramfs-kernel.bin
Checking upgrade image...Upgrade image does not support the device. Upgrade failed.

Wiki must be updated because users are getting stranded.

Now how can this be fixed?

Yes the work around is using the opennet site .TAR version but there should be another way to fix this.

1 Like

I suggest to raise this topic on the developer mailing list and / or create a bug report.

1 Like