Install crashed on WCR-1166-DS

Hi !
Just bought a WCR-1166-DS on ebay with intention to convert it to openwrt.

I downloaded this image:
Get in the GUI, found "update firmware" area (in japanese, pretty fun...)
launched the update.
There was a gauge in original firmware, so I waited to reach 100%
then it started to blink yellow/orange every ~15sec, but no available.

After a while, I tried a reboot, no change...

So I searched the forum and found this topic:

I download "initramfs" firmware provided by @musashino on post #3, setup a tftp server as explained and reboot my router pressing the button,as explained in provided link.

The router seems to find the tftp image, because on my laptop acting as tftp server, I can see this

 tail -200f  /var/log/syslog | grep tftp
Jul  2 21:03:08 celestin tftpd[14885]: tftpd: trying to get file: linux.trx-recovery
Jul  2 21:03:08 celestin tftpd[14885]: tftpd: serving file from /tftpboot

The power led blink during about ~10sec (firmware download ?)
and then, the power led stay ON.
Other leds are off (no 15sec blinking like previously).

Still no openwrt page...
I did a power cycle after a few minutes, and no progress....(maybe a few minute is not enough ? is it possible that it was in flashing process?)

What can I do ?

(PS: this is my 1st flashing of openwrt...all is new to me in this)

gosh, after a while, I read somewhere that initramfs are ram install? not flashed?

So I was doing a power cycle after flashing: it was loosing the firmware :crazy_face::crazy_face:

So I flashed again not power cycle reconfigure my laptop ethernet to DHCP client instead of TFTP server, switch off/switch on my ethernet interface on laptop, reconnect......magic !!! I have a 192.168.1.x address given by the WCR1166DS !!

So I get in Luci, downloaded the 18.06.2 sysupgrade image, flashed I am, let's see what's next :slight_smile:

1 Like

If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

I ran into the same problem, same router. Is there a guide on how to setup this tftp server? I tried on two different machines and OS with no success. The greatest problem is that none of the servers give any feedback on whether any router requested an IP or not. (I shouldn't have gotten into this given my lack of knowledge of this topic) I am pretty clueless. Also @musashino 's firmware is no longer online. I tried using the factory firmware and the openwrt firmware aswell.

What I understood is that tftp is used to make a directory available to whichever device connects to that ethernet port, and that the router on the other hand tries to download a file called "linux.trx-recovery" every time it boots if AOSS button is pressed. Is this right?

  • What is the recommended software for starting the tftp?
  • on which of the two router's plug should I connect the ethernet cable? (lan/internet)
  • how do you tell that a connection to the tftp was requested?
  • what does the "serverip is" instruction mean, at ? I haven't found any tftp software that lets you chose an IP beside atftp, which seems to do nothing.

With the help of a friend managed to get this working. Here a brief guide considering the stuff that I didn't know, and was preventing me to succeed:

  • A raspberry pi is an easy way to make this process. Actually linux machines in general make it easier to control ports; my windows machine was doing too many things under the hood that I didn't know how to control.
  • A initramfs is not exactly the same as a firmware. They are compiled differently, so they cannot be used interchangeably. Initramfs is the one used to recover the router using tftp, whereas the firmware is what actually is flashed into the router.
  • I set-up a tftp port using tftpd-hpa. My friend recommended me to use this (I tried tftpd and atftp without success), I don't know yet why. There's a guide at
  • I made sure to know which device name actually is the ethernet plug, in order to refer to it correctly (I think I was writing the wrong name for it in the different config files one needs to do to setup the tftp).
  • For all this, a really useful tool, which my friend also recommended is wireshark. It was really vital in order to know where stuff is failing.
  • I set up the raspberry pi IP to static on the physical ethernet cable interface. This is what the router looks for.
  • Following the tftp guide, I made the initramfs file available under the name "linux.trx-recovery" in the tftp server. This is indicated by this guide:
  • Plug the router in while pressing the AOSS/WPS button, so that it engages this initramfs mode. At first I was too impatient. You actually need to hold the WPS button for about three seconds while it boots. It was possible to monitor whether it worked or not using wireshark. You would get someone with ip asking who has the IP Ah, also the plug onto which to connect the cable in the router is the "lan" one, and not the "internet" one.
  • If all works, you would get a long transmission of the file onto the router, which is very noticeable in wireshark (a sudden stream of many messages and ackowledgements between & ...2)
  • If you manage to transfer that image into the router, you need to either plug the router to other computer (what I did) or turn off the tftp on the machine, so that the router can connect like any normal router...
  • Now you are able to visit and see the captive portal of openWrt! As grenouille said, you shouldn't take out the power from the router, because this initramfs goes away every time you shut down the router
  • By using the openWrt portal, you upload the actual openWrt update image. This is an actual firmware writing, hence it makes the firmware to persist between power cycles.

I hope this helps any other person with a similar problem. I would have been completely unable if it weren't for @Avnerus patient guidance, IRL.

Btw; @musashino's initial post of initramfs went offline. It would have been a big hassle for me to compile it myself. However, it currently can be found at his repo: . Thanks for pointing that out!

1 Like

The official one doesn't work?

that's funny.. I didn't find that link. I still don't see it at
Anyways, good to know!