[INFO] Archer C2600 + PS4 Pro Wifi + ath10k-ct drivers


Yesterday updated my C2600 to the lastest snapshot running with ath10k-ct wifi drivers. After updating it, all my wifi devices worked fine, except for my PS4 Pro. I had connection to my SSID and also an IP assigned, but there was no way to connect Internet/PSN Network (the rest of devices were working fine).

To solve it, I just removed firmware CT + driver CT and installed non CT driver + firmware.
After doing that, worked again my PS4 Pro.

To sum up: If someone has problems with PS4 and CT drivers/firmware, change to non CT drivers.


1 Like

Can you let us know what version you're referring to as "latest"?

@lleachii Here comes the info my friend!!!

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 OpenWrt SNAPSHOT, r9732-63ed513779
root@C2600:~# uname -a
Linux C2600 4.14.107 #0 SMP Tue Mar 26 14:12:01 2019 armv7l GNU/Linux

I hope is enough!!


1 Like
jeff@deb-devel:~/devel/openwrt$ git log -1 63ed513779
commit 63ed513779
Author: Hauke Mehrtens <redacted>
Date:   Thu Mar 21 17:57:00 2019 +0100

Note that the CT firmware was updated on March 25th with

616ec4365c ath10k-ct: Update to 2019-03-25
f803ee3ba9 ath10k-firmware: update Candela Tech firmware images

(not known if the behavior has changed since the OP's report)

1 Like

There is an open ticket on the candela github site here that might be related. It may help to contribute your observation there. From the bug report, it seems 2.4 ghz works but 5 ghz does not.


1 Like

Tried today lastest snapshot version:

 OpenWrt SNAPSHOT, r9902-9424b6f
root@C2600:~# opkg list-installed | grep -i ath10
ath10k-firmware-qca99x0-ct - 2018-10-10-d366b80d-1
kmod-ath10k-ct - 4.14.113+2019-04-08-9cd701a4-1

Still not working.


The PS4 Pro does use Marvell 88W8897 Wireless chipset. Does this problem with ath10k-ct only affect this specific wifi chip with PS4 Pro software or is it a general incompatibility with all Marvell wifi clients affected? e.g. PS4 non-Pro, mvebu devices etc.

Try to install CT driver with classic firmware, for me it's the best compromise.

Tested and not working.

CT Firmware + CT Driver = Not Working
Classic Firmware + CT Driver = Not Working
Classic Firmware + Classic Driver = Working

Classic drivers and firmware is enough good on current muster brunch, just use it, i don't see any performance reduction on it compared to CT, it just works and works very stable.

I agree with you @GektorUA classic driver + classic firmware working like a charm my friend!!!

Sorry, I don't know. I have no more Marvell wifi clients to test it.

FYI this should be fixed in master now, the bug was identified and fixed in the ath10k-ct firmware.

1 Like