Increase 5ghz Tx power of WDS client above 20 dBm?

I am using an Archer C7 v2 as a WDS client. Everything is working OK but throughput is very low and my WDS server is reporting a very low signal from the Archer (-83 dBm); conversely, the signal from my server to the Archer is great (-56 dBm). I thought that this was super strange as the Archer typically has very decent wifi performance, but it turns out that it seems to be locked at a maximum of 20 dBm Tx power when in WDS client mode. The server is using 23 dBm (as I believe is the true maximum for the US region).

Is this really the driver default maximum Tx power or a firmware bug? It seems awfully low. I'm using channel 36. I've tried using ath10k-firmware-qca988x-ct-full-htt in addition to the stock ath10k-firmware-qca988x-ct with no difference (slightly better throughput but no ability to increase the Tx power).

Have you set your country correctly to "US"?
20 is the limitation for the default "00" or "world" setting.
https://git.kernel.org/pub/scm/linux/kernel/git/sforshee/wireless-regdb.git/tree/db.txt#n19

https://git.kernel.org/pub/scm/linux/kernel/git/sforshee/wireless-regdb.git/tree/db.txt#n1596

1 Like

Thanks, I had always been under the impression that the driver default was tied to the region of manufacturing. Now I can set it to 23 dBm and my throughput is about 20% better!

1 Like

That is highly dependent on the device you're using.
Some devices (like yours) follow what the OS sets (via the country setting).
Others have a built in power table but can be lowered only (not raised) by the OS.
Others just follow a built in power table no matter what you do.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.