Inconsistency in nanostation loco M2 firmware

Hi all,
I'm trying to upgrade new tiny firmware 22.03.5 on Nanostation Loco M2 (XM version) but it accept only nanostation XM firmware (and not Loco as it should be) so our Loco stop working because they don't see address.

Any help?
Tnx in advance

It worked for me. I used TFTP to install the factory file (this may not work with all bootloaders). Upgrading from a running OpenWrt could fail due to lack of RAM. This device is not very supportable since it only has 32 MB RAM.

Hi mk24, thanks for your answer. I already tried to replace the firmware with the openWRT factory days ago, and it worked with no problem; the problem is when I try to install the upgrade. Then I 'd like to know why the device accept the Nanostation XM firmware and not the Loco one's

I used the loco XM 22.03.5 factory file with a TFTP install, and it is running 22.03.5 the same as if it had been upgraded. There is no need to upgrade after installing the current version's factory file, it is the same code just with a header added so the bootloader understands it.

There is a serious shortage of RAM in this model thus I suggest TFTP installs instead of using sysupgrade as the latter requires storing the whole new firmware in the RAM disk while OpenWrt is running. You can backup your configuration to restore after TFTP flashing.

Thanks a lot mk24. I know I need no upgrade after installing last firmware version. As I told you I already made installation via TFTP with factory file with no problem, but I have a lot of Nanostation Loco all around Campus and restore a configuration backup (for all) after a factory flash is not an exiciting idea.

I still don't understand though, why my Loco accept only Nanostation M2 firmware and not Nanostation Loco M2 (bad image). Tried more then one.