Incomplete / mount options

hi guys.

I moved / to external USB stick connected to tplink c59v2 powered by:

root@a81m3:/home/sam# cat /etc/openwrt_release | grep DESC
DISTRIB_DESCRIPTION='OpenWrt SNAPSHOT r12138-1e3bfbafd3'

I setup following in /etc/config/fstab

root@a81m3:/home/sam# cat /etc/config/fstab
config 'global'
        option  anon_swap       '0'
        option  anon_mount      '0'
        option  auto_swap       '1'
        option  auto_mount      '1'
        option  delay_root      '5'
        option  check_fs        '0'

config 'mount'
        option target        '/'
        option device        '/dev/sda1'
        option fstype        'ext4'
        option options       'rw,sync,relatime,user_xattr,barrier=1,data=ordered'
        option enabled       '1'
        option enabled_fsck  '0'

whenever I reboot device, device is up and running, mounted / on /dev/sda1 but I see incomplete mount options (no "user_xattr,barrier=1,data=ordered")

root@a81m3:/home/sam# mount | grep /dev/sda1
/dev/sda1 on / type ext4 (rw,sync,relatime)

could you guys suggest why and how to mount root with these options? This is USB drive and I'd like to minimase writes on it

Thank you.