Inadvertent flash to a snapshot

While trying to get my TP-Link TL-WR1043ND Version 3 to 18.06.02 I inadvertently (dont ask) installed
SNAPSHOT r9298-8c9f255 / LuCI Master (git-19.038.66435-4e5111e)

Before I screw this thing up any more is there some standard proc for flashing from a snapshot to a stable release version (in this case 18.06.02) ?

1 Like

I can do all that but there is no way to do it the lazy way via LUCI ? I tried and I believe it complained with
'The uploaded image file does not contain a supported format' . Asked if I wished to 'force' which didn't seem like a good idea .

The command line sysupgrade is saying 'image metadata not found' and wants to know if I wish to 'force' which doesnt sound like a good idea .

This is the image I am using


You can always flash to stock firmware and then flash to 18.06.2 from there, if you want to be safe. It is fairly easy to do on the wr1043nd v3.

To flash to stock:

  1. Download the TL-WR1043nd v3 Firmware (150514) from TP-Link's website. (150514 will allow you to flash OpenWRT images)

  2. Unzip the Firmware. Rename the .bin file to something shorter. In this example I'll use 'wr1043ndv3.bin'

  3. SCP 'wr1043ndv3.bin' in to the /tmp directory on the router

  4. SSH in to the router's /tmp directory

  5. Execute the following command:
    dd if=wr1043ndv3.bin of=tplink.bin skip=257 bs=512
    (Stripping the uboot bootloader off the TP-Link firmware. If successful should have the output 15872+0 records in, 15872+0 records out)

  6. Flash the stripped stock firmware (tplink.bin) using the command:
    mtd -r write tplink.bin firmware

  7. Wait until router reboots and loads up. Flash OpenWRT 18.06.2 via the TP-Link Router Settings at

Yes, but you still have to install LuCI via the command line.

opkg update
opkg install luci

Then you can flash on the web GUI as you desire. Hope this helps.

this message from sysupgrade ' 'image metadata not found' is normal ?

Are you getting this message from the LuCI web GUI when flashing?

command line sysupgrade is saying 'image metadata not found'

GUI says 'The uploaded image file does not contain a supported format'

...and, you are trying to flash 18.06.2, correct?

yes , openwrt-ath79-generic-tplink_tl-wr1043nd-v3-squashfs-sysupgrade.bin

That's snapshot, not 18.06.2.
ath79 doesn't exist in 18.06.x.

1 Like

1 Like

Ok time for a sanity check on my part

root@OpenWrt:~# sysupgrade -T /tmp/openwrt-18.06.2-ar71xx-generic-tl-wr1043nd-v3-squashfs-sysupgrade.bin
Image metadata not found
Use sysupgrade -F to override this check when downgrading or flashing to vendor firmware
Image check 'fwtool_check_image' failed.

If you are now on a ath79 snapshot build, the sysupgrade in it really expects some metadata from the image, and 18.06.x does not have that in its image. So the error is quite logical.

You can override/bypass the check with "-F" option, just like your sysupgrade attempt tells you.

(Note: this of course assumes that you are trying to flash a correct image, as the checks are bypassed. You might in any case first use sha256sum to calculate the image hash in /tmo and check that from the download repo directory.)

I used mj5030 suggestion and reverted back to tplink fw and then flashed 18.06.2 .

I appreciate all the help :grinning:

1 Like

@pluffmud If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

You can also mark the reply that solved your problem:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.