In over my head, need help please

I think I may have jumped right in and now I'm in over my head with a new router and LEDE.

I was a little familiar with DD-WRT a few years ago when I bought a netgear router with it installed when I first signed up for PIA. I soon realized that router didn't have the processing power to use openvpn so I was using the PIA app on my mac.

Recently, I decided to buy a Linksys WRT3200ACM router and try the openvpn thing again. I did some research and realized openWRT was the new thing and decided to install LEDE on my router. I got it installed and got my wifi up and running but now when I looked in to setting up openvpn for PIA I'm not sure what I'm doing anymore. I went to and looked at his instructions but it talks about SSH and installing packages and I just don't feel confident in doing the right thing without a little help. And not sure if those instructions apply to LEDE.

So here I am. I need help figuring out where to go from here. Links to instructions or any advice is greatly appreciated.

Looking forward to learning more and getting this figured out. Thanks in advance.

And not sure if those instructions apply to LEDE.

Just about all instructions that apply to current versions of OpenWRT also apply
to LEDE, they have not diverged much.

Can you be more specific about what you need help with?

David Lang

Similar device setup

That's the thread that took me to I guess I wasn't sure if that thread and those instructions applied to the LEDE build.

Hi Crontegy

I setup openVPN on Ubuntu, Windows, Lede, openWRT, DD-WRT, MerlinWRT I can assure you if you use the same openVPN version, i.e. 2.3.6 on all then also on all the setup is identical as far as I can see.
Only difference is the syntax. And in Windows you use the GUI to bridge on Linux-distro you manually do that using telnet or ssh. Whatever you like more.

Luci also allows GUI bridging just as in Windows.

At least the logic and what has to be done is 100% identical.. just syntax and "where" you do your settings is different. If you understand what you're doign and what it all means, you just need to search the right locations on each distribution.

I think I'm done trying to figure this out. I can't even login to ssh anymore. Is there a way to reinstall linksys software?

Or is there a way to reset ssh password? I had to go month before continuing the setup and now I'm completely lost and forgot passwords. Can I just do a fresh LEDE install and start over?

Ok. I've looked into flashing factory firmware but there is a warning about resetting the vlan to default. Do I need to do this?

Guess no one is willing to help. I have tried flashing OEM software but it's not a bin file so it doesn't work. I've tried flashing DD-WRT and that doesn't work. I tried updating LEDE to start over and that didn't work. Still not bricked either believe it or not. And still can't login to SSH.

ANY help is appreciated. Thanks.

Wow. Ok. Message received. I will go elsewhere.

Just to continue on; this but like I said, I have never used this on one of these, so don't know the details. I don't use a mac so not sure what USB TTL cable to get, should not matter I would think, just any of the cheap ($2) ones you can find on ebay, just make sure there is a mac os driver for the thing. There is a picture on the wiki of the header (if you have some small clips you can probably use those), I have not popped the cover off my rango to see if things look the same as the picture on the wiki page.

Ok. So I still had linksys firmware on other partition. Woohoo! I got that working well enough and now that I know I can go back I feel like trying again. Can I just flash again? Is there a particular build I should use? Main reason I'm doing this is to setup PIA.

Thank you so much for getting me back on track.

Of course. If flashing from OEM use the factory image, if from a LEDE install use the sysupgrade image. There are now RC images of the first LEDE stable to be found here, gui in as part of the image.

I don't know what I'm looking at there. Are those current LEDE images to download?

Those are RC(Release Candidate) images of the LEDE-17.01 branch, or what will eventually be the first stable release for LEDE. You can expect that to be pretty stable with just some issues resolution changes to be added (hopefully).

I hope you will stick with me on this because I just don't understand. There are a ton of sub folders and I have no idea what I'm searching for, if anything. Are you saying that I should download one of those files to flash?

Thank you!

Yes, specifically from the mvebu directory (target build), the wrt3200acm build, factory or sysupgrade as per what you are flashing from; since I assume OEM you would want factory. You will than have to load whatever packages you require.

Ok. Thank you. So, as you can imagine, I don't know what packages I may need. Is there one for PIA setup? I hope that's not a really stupid question.

Also, I keep seeing there are wifi issues on the 3200. I see discussion here and on DD-wrt board. Has that been resolved?

Here is where to check on issues of mwlwifi, and yes we are still waiting on a blob update for the rango. As per packages to load you will have to read the wiki as to what is required for your needs, I just build an image with things baked-in.I think the OpenWrt OpenVPN wiki has recipes to follow if that is what you want to use.

Got it. I think I will leave it at that for now and do some looking around. I can't thank you enough for the help.