Impossible to update opkg

Hi,

here some spec:

root@OpenWrt:/etc/opkg# ubus call system board
{
        "kernel": "6.6.60",
        "hostname": "OpenWrt",
        "system": "ARMv8 Processor rev 4",
        "model": "Linksys E8450 (UBI)",
        "board_name": "linksys,e8450-ubi",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "SNAPSHOT",
                "revision": "r28085-6720c4ccba",
                "target": "mediatek/mt7622",
                "description": "OpenWrt SNAPSHOT r28085-6720c4ccba",
                "builddate": "1731596056"
        }
}
root@OpenWrt:/etc/opkg# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd83:4e9f:e4ec::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'
        option metric '5'
        option peerdns '0'
        list dns '9.9.9.9'
        list dns '1.1.1.1'

root@OpenWrt:/etc/opkg# cat /etc/config/wireless
config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/18000000.wmac'
        option band '2g'
        option htmode 'HT40'
        option channel '8'
        option country 'CA'
        option cell_density '0'
        option txpower '28'
        option noscan '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'xx'
        option encryption 'psk2'
        option key 'xx'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '5g'
        option he_su_beamformee '1'
        option he_bss_color '8'
        option cell_density '0'
        option country 'CA'
        option htmode 'HE80'
        option txpower '27'
        option channel '157'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'xx'
        option encryption 'psk2'
        option key 'xx'
root@OpenWrt:/etc/opkg# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option localservice '1'
        option ednspacket_max '1232'
        option rebind_protection '1'
        option localuse '1'
        option filter_aaaa '1'
        option allservers '1'
        option nonegcache '1'
        option cachesize '2500'
        option confdir '/tmp/dnsmasq.d'
        list server '/pool.ntp.org/1.1.1.1'
        list server '/time.cloudflare.com/1.1.1.1'
        list server '127.0.0.1#5353'
        option noresolv '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dnsmasq 'adblock_lean'
        list addnmount '/bin/busybox'
        option rebind_protection '0'
        option localservice '0'

root@OpenWrt:/etc/opkg# cat /etc/config/firewall

config defaults
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'
        option flow_offloading '1'
        option flow_offloading_hw '1'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config redirect 'dns_int'
        option name 'Intercept-DNS'
        option family 'any'
        option proto 'tcp udp'
        option src 'lan'
        option src_dport '53'
        option target 'DNAT'

root@OpenWrt:/etc/opkg# 

also, we can not see it above but in LuCi in overview, it says : 24.10

	OpenWrt SNAPSHOT r28085-6720c4ccba / LuCI openwrt-24.10 branch 24.312.73405~8f7f142

I did not upgrade it since a while, but the opkg update worked before, internet wifi is working great too right now.

opkg update
Downloading https://downloads.openwrt.org/snapshots/targets/mediatek/mt7622/packages/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/targets/med
iatek/mt7622/packages/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/base/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/aa
rch64_cortex-a53/base/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/luci/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/aa
rch64_cortex-a53/luci/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/packages/Package
s.gz
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/aa
rch64_cortex-a53/packages/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/routing/Packages
.gz
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/aa
rch64_cortex-a53/routing/Packages.gz

Collected errors:
* opkg_download: Failed to download https://downloads.openwrt.org/snapshots/targets/mediatek/mt
7622/packages/Packages.gz, wget returned 8.
* opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/aarch64_co
rtex-a53/base/Packages.gz, wget returned 8.
* opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/aarch64_co
rtex-a53/luci/Packages.gz, wget returned 8.
* opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/aarch64_co
rtex-a53/packages/Packages.gz, wget returned 8.
* opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/aarch64_co
rtex-a53/routing/Packages.gz, wget returned 8.
root@OpenWrt:/etc/opkg#

recent snapshots use apk.

2 Likes

I tried both and I tried also on LuCi in software and same error.

if this is a pre 24.10 snapshot, I can imagine those files aren't available any more, because of the apk migration.

3 Likes

1731596056 is Thu Nov 14 14:54:16 GMT 2024

So this is a very outdated snapshot, pre-dating the changeover to apk.

Also, luci coming up with 24.10 means you have somehow ended up with a broken hybrid.

So, basically, you need to reflash with today's snapshot, if it is snapshot you really need, or reflash with 24.10.0 if you don't.

3 Likes

Adding to that, if you are going to use snapshot builds (any of them: branches or main), then you need to be fairly diligent about upgrades. I'd suggest once per week, as they age out rather quickly and become unmaintainable due to the fact that packages are not retained for very long and upgrading becomes a much bigger task (as you are now experiencing).

The proper choice to avoid this is to get on a release branch. As @bluewavenet suggests, 24.10 is probably your best bet.

You can sysupgrade to 24.10

1 Like

if you want to stay on 24.10 snapshots with opkg, you can find them at https://downloads.openwrt.org/releases/24.10-SNAPSHOT/.

1 Like

I use the linksys ea8450, I think I need to do something about the upgrade with UBI Installer.....?

I don't own one, but I believe it's described in https://openwrt.org/toh/linksys/e8450.

1 Like