ImageBuilder unable to open feeds configuration at line 48?

Good morning,

Say we're running into an issue with ImageBuilder; we've got an SDK configured and we want to move to a new ImageBuilder so we can take advantage of a patch from January in fstools.

The old ImageBuilder and SDK work great -- no issues. But the new one I downloaded from here:

Gives an error when we go to build images:

Package list missing or not up-to-date, generating it.
Building package index...
{it downloads all the packages}
Unable to open feeds configuration at /home/buildserver/output/img/scripts/feeds line 48.
Pseudo file "/dev" exists in source filesystem "/home/buildserver/output/img/build_dir/target-mipsel_24kc_musl/root-ramips/dev"
Ignoring, exclude it (-e/-ef) to override.
2797+1 records in
2797+1 records out
1432411 bytes (1.4 MB, 1.4 MiB) copied, 0.00495013 s, 289 MB/s
2705+1 records in
2705+1 records out
1385166 bytes (1.4 MB, 1.4 MiB) copied, 0.005159 s, 268 MB/s
padding image to 002b0000
padding image to 002c0000
an error occured while making the image: Error: ENOENT: no such file or directory rename 'home/buildserver/output/lede-ramips-mt76x8-gl-mt300n-v2-squashfs-sysupgrade.bin' -> '/home/buildserver/output/s_upgrade.bin'

So because that feeds configuration isn't updating or can't be accessed for some reason it causes the build to fail.

Any ideas?


Bump—any ideas?

You might give some more details...

what worked, more exactly "old ImageBuilder and SDK"?

What is the working feeds definition?
What is the failing?
and what is the difference ni the directory contents?

And are using also a new matching SDK that matches the new Imagebuilder?

@hnyman could you please check FS#1608

Thank you

Hi, I also am seeing the same thing using 18.06.2 with a glinet ar300m.
I checked the link you suggested but that doesn't seem to have a solution either unless I am missing it.

Suggested Link:

I did however find in one post that the error can be overlooked at simply a warning.

@cvocvo, did you find a way to solve this?

If I recollect we solved this by re-downloading everything (sdk, imagebuilder, packages) and then re-configuring everything.

1 Like

Thank you. I'll do that.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.