Image without Dropbear - SOS

Hi there! I'm new on the OpenWRT world, but I've read lots of forums. The thing is I've made a mistake, and now can't access my router.
My router is:
TP-Link TL-WR740N v4.20 (poor flash and ram)

My original needs:
I need to install Bandwidthd to monitor all bandwidth through my router, but as my Flash and Ram memory are poor, I couldn't install it via Opkg, even if I try. So I started trying to build my own image using the ImageBuilder from here:
I used the one Imagebuilder from the bottom of the page.

My problem:
As the title say, I didn't install Dropbear.
I used this command:

make -j4 image PROFILE=tl-wr740n-v4 PACKAGES="-libiwinfo-lua -liblua -libubus-
lua -libuci-lua -lua -luci -luci-app-firewall -luci-base -luci-lib-ip -luci-lib-nixio -luci-mod-admin-full -luci-proto-ipv6 -luci-proto-ppp -luci-theme-bootstrap -dnsmasq -dropbear -ip6tables -odhcp6c -odhcpd-ipv6only bandwidthd-pgsql"

I avoided those LuCi packages to save memory, but following that way I didn't install Dropbear...

Now I can't access my router via SSH nor Telnet.
I also tried with scp but didn't worked at all, even with FailSafe mode.

I have now the Sysupgrade Image but can't access to the router to flash it.
Any suggestion?

I reach it with ping, so its responding.

There is no telnetd anymore. If you did include luci, that might be an option, if you didn't - the device might (or might not) have push-button tftp recover support, if it doesn't - you'd need a serial console to recover (but that's probably not worth buying for the device in question).


I didn't include LuCi.
It has only 3 buttons on the back: Power On/Off, Reset (the one thats kinda inside it) and one button with the legend QSS

Check the device page as linked by mpa in the next post. TP-Link devices generally have a TFTP recovery that can be triggered during early boot.

Note that the OpenWrt site is openwrt.ORG, not the "squatters" that I mistakenly linked previously.


See this device page and its debricking section.

I solved my problem!!
I followed this guide Tftp secret of TL-WR740N uncovered.
The steps are easier than one would think. Just plug the router's power cord, push the power button (set it on off position), insert some "pin" in the RESET button, turn the router on and release the RESET button after 3-5 sec. The leftmost and the rightmost light has to be on and locked, then you know it entered the Recovery Mode.
It does not work if the 2nd light is blinking as hell. Just know it when border lights are blocked.

Thanks to all!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.