Image Building Issues (x64)

I am trying to build a squashfs image for x86_64 with a bigger kernel and root partition but the image will not build correctly.

The only thing that is modified in the .config file is

CONFIG_TARGET_KERNEL_PARTSIZE=32
CONFIG_TARGET_ROOTFS_PARTSIZE=2048

When trying to create the image using this command the profile option it says profile generic doesn't exist and doesn't build.

make image PROFILE=generic BIN_DIR=/firmware FILES=./files PACKAGES="unzip tar htop fdisk"
make image PROFILE-generic BIN_DIR=/Firmware FILES/files PACKAGES "unzip tar htop fdisk"
Profile "generic" does not exist!
Use "make info to get a list of available profile names.
make[1]: *** [Makefile:218: check profile] Error 1
make: *** [Makefile:240: image] Error 2

When using the command without the profile flag option:

Building images... 
bash: line 1: /firmware/openwrt-22.03.0-rc6-x86-64-generic-rootfs.tar.gz: Permission denied
make[3]: *** [Makefile:156: kernel prepare] Error 1
make[2]: *** [Makefile:188: build_image] Error 2 
make[1]: *** [Makefile:126: _call_image] Error 2
make: *** [Makefile:242: image] Error 2

The issue will occur even if the firmware folder was created before trying to build the image.

When using sudo:

Linux-x86_64/staging_dir/host/bin/grub-bios-setup: warning: Your B105 Boot Partition is under 1 MiB, please increase its size..

Okay so placing quotes around some of the command has fixed a issues.

Changing /firmware to ./firmware also seems to help with the permission issue.

make image PROFILE="generic" BIN_DIR="./firmware" FILES="./files" PACKAGES="unzip tar htop fdisk"

However, the ./firmware is not found anywhere. Using the find command it's not there.

Also This issue still occurs:

warning: Your BIOS Boot Partition is under 1 MiB, please increase its size..

not a solution, but a workaround ...
why not settle with the default image, then simply fire up gparted from a thumb drive and resize the partitions ?

This dir has to be created manually, it's where your config files will be stored. If you dont need/want to add configs files within the image, just don't use the FILES option.

Furthermore there is no need for the PROFILE option with the x64 builder.

Sorry forgot to mention this a squashfs system.

Thank you

@takimata solved it!

The fix to this is:

make image PROFILE="generic" FILES="./files" PACKAGES="unzip tar htop fdisk"

The images show up in bin/targets

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.