Image builder creating problematic image


My first post here, I have been using image builder for a long but recently I tried to update firmware on Xiaomi MI Router 4A Gigabit with 22.03.5 and 5ghz band doesn't work. It shows up from the router but can not see from any device so can not connect.

I tried to eliminate other factors, without adding/removing packages and I even used same VirtualBox snapshot which created my old image (22.03.2) and still same result. Configurations seems Okay as same gz file can be used on stock built firmware (23.3.5 or any version) and 5ghz works as expected.

It's there anything changed with mt7621 devices tree? (Or at least for MI Router 4A Gigabit), because I am doing things, same way using same machine and getting unexpected problem. (Even though my built image flashes, it gives ubus error while flashing, but I got same error while flashing pre-built image too and 5ghz worked)

Any help would greatly appreciated. I do not want to modify image too much, just want to have my configurations as factory defaults on my router.