I'm looking for kmod-rt2800-usb package for openwrt 18.06

I'm looking for kmod-rt2800-usb package for openwrt 18.06

when I go to install this kmod-rt2800-usb package in the software section, it says so:

Installing kmod-rt2800-usb (4.14.169+5.4-rc8-1-1) to root...
Downloading http://downloads.openwrt.org/snapshots/targets/brcm63xx/generic/packages/kmod-rt2800-usb_4.14.169%2b5.4-rc8-1-1_mips_mips32.ipk

Collected errors:


 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-rt2800-usb:
 * 	kernel (= 4.14.169-1-9f8a5b88700f1d4044ca213af45c09db) * 	kernel (= 4.14.169-1-9f8a5b88700f1d4044ca213af45c09db) * 	kernel (= 4.14.169-1-9f8a5b88700f1d4044ca213af45c09db) * 	kernel (= 4.14.169-1-9f8a5b88700f1d4044ca213af45c09db) * 
 * opkg_install_cmd: Cannot install package kmod-rt2800-usb.

is it possible to have this package that suits us? thank you very much

OpenWrt SNAPSHOT r7946-2c01425d2d / LuCI Master (git-18.232.74480-b93d3f3)
model Huawei EchoLife HG553
Architecture bcm63xx/HW553 (0x6358/0xA1)
Kernel 4.14.66

https://openwrt.org/faq/cannot_satisfy_dependencies
Snapshots are updated daily. If you install packages the next days there will be unsolvable dependencies.