Ignore upstream DHCP server

Hello,

My ISP won't allow me to configure my ONU (a FiberHome HG6245D) as a bridge device, so I resorted to setting up a DMZ and adding my OpenWrt'd Archer C7 v4 router to it.

On the router's config I set the WAN as described in https://openwrt.org/docs/guide-user/network/wan/dmz-based-bridge-mode and everything is sort of working, but any devices I connect to the router's LAN ports are assigned IPs by the DHCP running on the HG6245D instead of using the OpenWrt's.

Is there a way to block the upstream DHCP or any other way of disabling it's use by the devices attached to the router? As a workaround, I disabled the DHCP on the HG6245D, but that keeps me from using it's Wi-Fi.

My ONU is in the 192.168.2.0/24 range and the router is in the 192.168.1.0/24.

You either run the router in bridge mode or dumb AP with only one IP address, or as a router with two IP addresses. You cannot have both.

If you cannot reconfigure the ONU, I would run the router in bridge mode, to avoid the double NAT. There is no reason why the wireless devices cannot get an IP address from the ONU, if everything is properly configured.

Actually, I have 2 connections on the premisses: a cable modem that is on bridge mode and the Fiber that was just installed and I'm not able to bridge and I'd like to use mwan3 to load balance both.