IGMPv3 via wifi (dumb ap) - igmp-proxy necessary?

I want to connect my Telekom Media Receiver 601 via wifi to my main network. Connection via cable isn't possible. I want to use OpenWrt only on the two access points needed for the connection. Currently I don't get it to work with my two Netgear EX7300 flashed to OpenWRT because I'm not really sure how to configure it properly.

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option netmask '255.255.255.0'
        option gateway '192.168.x.1'
        option ipaddr '192.168.x.254'
        list dns '192.168.x.1'
        option igmp_snooping '1'
        option stp '1'

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'VHT80'
        option legacy_rates '0'
        option country 'DE'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option key 'secretpassword'
        option encryption 'psk2'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option channel '5'
        option legacy_rates '0'
        option htmode 'HT40'
        option country 'DE'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option key 'secretpassword'
        option encryption 'psk2'

I haven't started configuring the second wifi bridge because if i connect to the "OpenWrt"-Wifi I don't get a working stream. Devices connected directly to my Netgear GS108PE are working fine, IGMP snooping is enabled on the switch.

I started looking at igmp-proxy config but I'm not sure if it is really needed and how it should get configured because I don't have a upstream or downstream interface. Acting as "dumb AP", firewall and routing etc is disabled.