Igmpproxy won't start

Hi,

OpenWrt 18.06.1 r7258-5eb055306f
CPU x64
igmpproxy 0.2.1-2
I installed and configured igmpprxy, but not working. Won't Start.

I try to debug:
commnd: igmpproxy -d -v /etc/igmpproxy.conf

return error:
adding VIF, Ix 0 Fl 0x0 IP 0x6f00a8c0 br-lan, Threshold: 1, Ratelimit: 0
There must be at least 1 Vif as upstream.

my config files:

/etc/config/igmpproxy

config igmpproxy
	option quickleave 1
	option verbose 2

config phyint wan
	option network wan
	option direction upstream
	list altnet 0.0.0.0/0

config phyint lan
	option network lan
	option direction downstream

/etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdb4:50f4:9201::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'dhcp'

config interface 'wan'
	option proto 'dhcp'
	option type 'bridge'
	option igmp_snooping '1'
	option ifname 'eth1 eth2'

config interface 'wan6'
	option ifname 'eth1'
	option proto 'dhcpv6'

/etc/config/firewall + default configuration

config rule
        option src wan
        option proto igmp
        option target ACCEPT

config rule
        option src wan
        option proto udp
        option dest lan
        option dest_ip 224.0.0.0/4
        option target ACCEPT

config rule
        option src wan
        option proto udp
        option dest_ip 224.0.0.0/4
        option target ACCEPT

I figured out that igmpproxy read conf from /etc/igmpproxy.conf not from /etc/config/igmpproxy? How are this two files related?

The init script translates /etc/config/igmpproxy into a suitable format. Always use the init script to (re)start the process when you work with /etc/config/* files.

config interface 'lan'
		option proto 'dhcp'

config interface 'wan'
	option igmp_snooping '1'

Why you set lan interface to dhcp ?
Normally, igmp snooping are on downstream interface (lan).

1 Like

Hi @leeandy

Thanks for advice :smile:
I setup lan interface dhcp because I have a dhcp server in my network and I control all ip's form dhcp server.

I changed igmp snooping to lan. My network configuration now looks like this:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdb4:50f4:9201::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'dhcp'
	option igmp_snooping '1'

config interface 'wan'
	option proto 'dhcp'
	option type 'bridge'
	option ifname 'eth1 eth2'

config interface 'wan6'
	option ifname 'eth1'
	option proto 'dhcpv6'

Now I see igmpproxy under process but when I try to run chennel under the vlc

udp://@232.2.1.53:5002

channel won't show. How to check what is wrong? :frowning_face:

DEBUG MESSAGES:

Tue Nov 13 20:34:25 2018 user.notice igmpproxy[4426]: RECV Membership query   from 192.168.0.111   to 224.0.0.1
Tue Nov 13 20:34:26 2018 user.notice igmpproxy[4426]: The IGMP message was local multicast. Ignoring.
Tue Nov 13 20:34:26 2018 user.notice igmpproxy[4426]: RECV V2 member report   from 192.168.0.42    to 232.2.1.53
Tue Nov 13 20:34:26 2018 user.debug igmpproxy[4426]: Should insert group 232.2.1.53 (from: 192.168.0.42) to route table. Vif Ix : 0
Tue Nov 13 20:34:26 2018 user.info igmpproxy[4426]: Updated route entry for 232.2.1.53 on VIF #0
Tue Nov 13 20:51:17 2018 user.notice igmpproxy[1841]: RECV V2 member report   from 192.168.0.42    to 232.2.1.53
Tue Nov 13 20:51:17 2018 user.debug igmpproxy[1841]: Should insert group 232.2.1.53 (from: 192.168.0.42) to route table. Vif Ix : 0
Tue Nov 13 20:51:17 2018 user.debug igmpproxy[1841]: No existing route for 232.2.1.53. Create new.
Tue Nov 13 20:51:17 2018 user.debug igmpproxy[1841]: Found existing routes. Find insert location.
Tue Nov 13 20:51:17 2018 user.debug igmpproxy[1841]: Inserting at beginning, before route 224.0.1.60
Tue Nov 13 20:51:17 2018 user.info igmpproxy[1841]: Inserted route table entry for 232.2.1.53 on VIF #0
Tue Nov 13 20:51:17 2018 user.debug igmpproxy[1841]: Joining group 232.2.1.53 upstream on IF address 192.168.1.1
Tue Nov 13 20:51:17 2018 user.notice igmpproxy[1841]: joinMcGroup: 232.2.1.53 on br-wan

some help for this error ?

Tue Nov 13 22:28:39 2018 user.warn igmpproxy[6668]: No interfaces found for source 177.22.42.200
Tue Nov 13 22:28:39 2018 user.warn igmpproxy[6668]: No interfaces found for source 177.22.42.200
Tue Nov 13 22:28:40 2018 user.warn igmpproxy[6668]: No interfaces found for source 177.22.42.200
Tue Nov 13 22:28:41 2018 user.warn igmpproxy[6668]: No interfaces found for source 177.22.42.200

some some freeze in my Iptv

Try edit like this:

config interface 'wan'
	option proto 'dhcp'
	option type 'bridge'
	option ifname 'eth1 eth2'
        option defaultroute '0’
        option peerdns '0’

stop igmp service:
service igmpproxy stop

and run to see what happen:
igmpproxy -n -d -v -v /var/etc/igmpproxy.conf

If not work, pls provide details your network topology.

I try this but channels still not working (no change from previus configuration).

My network look like this:
Openwrt is guest on hiyper-v 2016 server.

eth0 is connected to my LAN with DHCP-IP192.168.0.111
eth1 and eth2 is conected to isp modem to trunk port trough one cable and
separated on hyper-v host to two network eth1 (DHCP-IP 192.168.1.1 is direct eth2 is vlan3999.

root@OpenWrt:~# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-lan state UP qlen 1000
    link/ether 00:15:5d:c8:04:28 brd ff:ff:ff:ff:ff:ff
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-wan state UP qlen 1000
    link/ether 00:15:5d:c8:04:2a brd ff:ff:ff:ff:ff:ff
6: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 00:15:5d:c8:04:28 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.111/24 brd 192.168.0.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fe80::215:5dff:fec8:428/64 scope link
       valid_lft forever preferred_lft forever
7: br-wan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 00:15:5d:c8:04:2a brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-wan
       valid_lft forever preferred_lft forever
    inet6 fe80::215:5dff:fec8:42a/64 scope link
       valid_lft forever preferred_lft forever

What this message mean I don't have any device on ip 192.168.1.1?

Leaving group 224.0.1.60 upstream on IF address 192.168.1.1

I guess you meant 2 separate sentences:

This means that igmpproxy left a multicast group.

Of course you don't. By default this address is your OpenWrt router. The error message clearly says: Leaving group on the INTERFACE with the address of 192.168.1.1. This means the software left the upstream multicast group 224.0.1.60 for all devices on interface WAN (in your case, you assigned your WAN 192.168.1.1).

This also means that igmpproxy must be running.

This also means that you need an igmpproxy on your upstream router, too.

Thanks @lleachii for answer.

This also means that you need an igmpproxy on your upstream router, too.

How can I do that?

My all devices are on LAN interface, probably because of that my iptv on my laptop not working? My laptop has address 192.168.0.42 and I open udp on vlc udp://@232.2.1.53:5002 and is not working.

igmpproxy message:

Tue Nov 13 20:51:17 2018 user.notice igmpproxy[1841]: RECV V2 member report   from 192.168.0.42    to 232.2.1.53
Tue Nov 13 20:51:17 2018 user.debug igmpproxy[1841]: Should insert group 232.2.1.53 (from: 192.168.0.42) to route table. Vif Ix : 0
Tue Nov 13 20:51:17 2018 user.debug igmpproxy[1841]: No existing route for 232.2.1.53. Create new.
Tue Nov 13 20:51:17 2018 user.debug igmpproxy[1841]: Found existing routes. Find insert location.
Tue Nov 13 20:51:17 2018 user.debug igmpproxy[1841]: Inserting at beginning, before route 224.0.1.60
Tue Nov 13 20:51:17 2018 user.info igmpproxy[1841]: Inserted route table entry for 232.2.1.53 on VIF #0
Tue Nov 13 20:51:17 2018 user.debug igmpproxy[1841]: Joining group 232.2.1.53 upstream on IF address 192.168.1.1
Tue Nov 13 20:51:17 2018 user.notice igmpproxy[1841]: joinMcGroup: 232.2.1.53 on br-wan

OK...

  • Where is the server that provides 232.2.1.53?
    • Your ISP (WAN)?
    • Your server on LAN

Your WAN is:

This isn't a public IP address, so where is the IPTV server located???

232.2.1.53 is ISP (WAN)

This isn't a public IP address, so where is the IPTV server located???
I don't understand, please explain more.

root@OpenWrt:~# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-lan state UP qlen 1000
    link/ether 00:15:5d:c8:04:28 brd ff:ff:ff:ff:ff:ff
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-wan state UP qlen 1000
    link/ether 00:15:5d:c8:04:2a brd ff:ff:ff:ff:ff:ff
4: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-wan state UP qlen 1000
    link/ether 00:15:5d:c8:04:2d brd ff:ff:ff:ff:ff:ff
5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 00:15:5d:c8:04:28 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.111/24 brd 192.168.0.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fe80::215:5dff:fec8:428/64 scope link
       valid_lft forever preferred_lft forever
6: br-wan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 00:15:5d:c8:04:2a brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-wan
       valid_lft forever preferred_lft forever
    inet6 fe80::215:5dff:fec8:42a/64 scope link
       valid_lft forever preferred_lft forever

You WAN IP is a RFC1918 address (192.168.1.1/24). This makes me believe that you have another router installed upstream on this 192.168.1.0/24 network.

Since your ISP provides IPTV and you seem to have another router upstream, that device also needs to be running igmpproxy. That simple.

No I am using openwrt as virtual guest on hyper-v server 2016. eth0 is connected to my LAN and ip address is of openwrt virtual router is 192.168.0.111. eth1 and eth2 are connected to ISP modem to TRUNK PORT and get the dhcp address 192.168.1.1 from it. IGMPPROXY is running on openwrt virtual router.

Doesn't matter if it's virtual or hardware.

OK, I read that twice above.

OK...not sure why you have 2 interfaces connected, though. This may be your issue, since IGMP is interface-based.

You still didn't answer - is your upstream router running igmpproxy??? ...or can you confirm access to this IPTV stream by plugging directly into your ISP's modem's Trunk Port (you can configure a VLAN on your computer, or setup your OpenWrt as a switch with tagged to the modem and untagged port to your PC)?

Yes I can confirm that IPTV is working on that port.

You still didn't answer - is your upstream router running igmpproxy???

IGMPPROXY only working on virtual openwrt router.

OK... not sure why you have 2 interfaces connected, though. This may be your issue, since IGMP is interface-based.

eth1 is tagget vlan3999
eth2 is untagget vlan7

boath port are connected to port 4 (TRUNK PORT) on ISP MODEM

I try to remove eth2, still no joy:(

Untitled%20Diagram
network diagram

Your explanations still not clear. Your ISP modem is running NAT-routing mode or bridge mode ? I think you running double NAT, that's why igmpproxy don't work.

1 Like

Hi @leeandy

Why then iptv is working on windows virtual guest connected to same port. On that machine I use program multicast2unicast. More on this LINK. Only difference is that I must set ETH4 port on modem to VIDEO.

any idea?

Thx again for trying to help