Igmpproxy multicast udp from WAN to LAN not routed

Hello,
I'm afraid I need to open another thread for help in regard to multicast routing now sending packages from WAN to LAN. I've spend more than a month reading and testing everything that is written but I come up to certain points that has never been discuss. The problem also is that most of the threads regarding this problems are not properly resolved. After having simplified the problem as much as possible, I'm going to explain what I see.

/etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'

config interface 'lan'
	option type 'bridge'
	option igmp_snooping '1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.2'
	option device 'eth1'

config interface 'wan'
	option device 'eth0'
	option proto 'static'
	option ipaddr '192.168.3.2'
	option netmask '255.255.255.0'

config interface 'ppp0'
	option proto 'pppoe'
	option device 'eth0'
	option username '...'
	option password '...'

config device
	option name 'eth1'
	option multicast_router '1'
	option igmpversion '2'

config device
	option name 'eth0'

/etc/config/firewall

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

/etc/config/igmpproxy

config igmpproxy
	option quickleave 1

config phyint
	option network wan
	option zone wan
	option direction upstream
 	list altnet 0.0.0.0/0

config phyint
	option network lan
	option zone lan
	option direction downstream

A join goes from lan to wan and up to the IPTV server. Then I see lot of udp traffic arriving to the wan port. notice the amount of milliseconds between packages is really small

tcpdump -i eth0 -nn host 239.0.2.30

19:43:52.652478 IP 172.26.20.39.17814 > 239.0.2.30.22222: UDP, length 49
19:43:52.652550 IP 172.26.20.39.17814 > 239.0.2.30.22222: UDP, length 49
19:43:52.652595 IP 172.26.20.39.17814 > 239.0.2.30.22222: UDP, length 49
19:43:52.652665 IP 172.26.20.39.17814 > 239.0.2.30.22222: UDP, length 210
19:43:52.652739 IP 172.26.20.39.17814 > 239.0.2.30.22222: UDP, length 210
19:43:52.652826 IP 172.26.20.39.17814 > 239.0.2.30.22222: UDP, length 210
19:43:52.711338 IP 192.168.3.1 > 239.0.2.30: igmp query v2 [gaddr 239.0.2.30]
19:43:52.732428 IP 192.168.3.2 > 239.0.2.30: igmp v2 report 239.0.2.30
19:43:52.748038 IP 192.168.3.1 > 239.0.2.30: igmp query v2 [gaddr 239.0.2.30]
19:43:52.769010 IP 172.26.20.39.17814 > 239.0.2.30.22222: UDP, length 171
19:43:52.769140 IP 172.26.20.39.17814 > 239.0.2.30.22222: UDP, length 206
19:43:52.769220 IP 172.26.20.39.17814 > 239.0.2.30.22222: UDP, length 242
19:43:52.769334 IP 172.26.20.39.17814 > 239.0.2.30.22222: UDP, length 877
19:43:52.885743 IP 172.26.20.39.17814 > 239.0.2.30.22222: UDP, length 206
19:43:52.885901 IP 172.26.20.39.17814 > 239.0.2.30.22222: UDP, length 259
19:43:52.886101 IP 172.26.20.39.17814 > 239.0.2.30.22222: UDP, length 206

The same in the lan interface 'eth1' shows very little traffic. Just the traffic to request joins from lan, but no packages from wan down to lan. Notice the amount of "seconds" between packets.

tcpdump -i eth1 -nn host 239.0.2.30

19:46:25.896279 IP 192.168.1.134 > 239.0.2.30: igmp v2 report 239.0.2.30
19:46:30.528565 IP 192.168.1.2 > 239.0.2.30: igmp query v2 [gaddr 239.0.2.30]
19:46:30.566326 IP 192.168.1.73 > 239.0.2.30: igmp v2 report 239.0.2.30
19:46:32.808995 IP 192.168.1.134 > 239.0.2.30: igmp v2 report 239.0.2.30
19:46:32.859744 IP 192.168.1.2 > 239.0.2.30: igmp query v2 [gaddr 239.0.2.30]
19:46:32.872228 IP 192.168.1.134 > 239.0.2.30: igmp v2 report 239.0.2.30
19:46:34.600477 IP 192.168.1.134 > 239.0.2.30: igmp v2 report 239.0.2.30

And this is the output of ip mroute. It looks like igmp cannot create the proper route for packets to be forwarded back to lan?

  • What Iif: unresolved State: unresolved means?
root@jo-con-el:/etc/config# ip mroute
(192.168.3.1,239.0.2.30)         Iif: eth0       Oifs: eth1  State: resolved
(192.168.3.2,239.0.2.30)         Iif: unresolved  State: unresolved

This is taking me crazy!

Thanks for any help

Adding complete list of firewall configuration

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option drop_invalid '1'
	option synflood_protect '1'
	option synflood_rate '25/s'
	option synflood_burst '50'
	option tcp_ecn '1'
	option tcp_syncookies '1'
	option tcp_window_scaling '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'lan'

config zone
	option name 'wan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option network 'wan ppp0'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-RIP-from-movistar'
	option src 'wan'
	option proto 'udp'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-IGMP-MovistarTV'
	option src 'wan'
	option proto 'udp'
	option dest_ip '224.0.0.0/4'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config rule
	option name 'Support-UDP-Traceroute'
	option src 'wan'
	option dest_port '33434:33689'
	option proto 'udp'
	option family 'ipv4'
	option target 'REJECT'
	option enabled 'false'