IEEE 802.11: disconnected due to excessive missing ACKs

Hi, I've a WE826-T2 4G Router with this configuration:
Architecture MediaTek MT7620A ver:2 eco:6
Firmware Version GoldenOrb_2020-03-01 ( OpenWrt 18.06.7 )
Kernel Version 4.14.167

After a few hours of using it or after one day I got this messages, and I lost my wifis connection.
Log:

Thu Jul 23 11:48:15 2020 daemon.info hostapd: wlan0: STA bc:a9:20:93:a6:91 IEEE 802.11: disconnected due to excessive missing ACKs
Thu Jul 23 11:48:15 2020 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED bc:a9:20:93:a6:91
Thu Jul 23 11:48:18 2020 daemon.info hostapd: wlan0: STA 50:c8:e5:61:0c:35 WPA: group key handshake completed (RSN)
Thu Jul 23 11:48:19 2020 daemon.notice hostapd: wlan0: STA bc:a9:20:93:a6:91 IEEE 802.11: did not acknowledge authentication response
Thu Jul 23 11:48:21 2020 daemon.info hostapd: wlan0: STA bc:a9:20:93:a6:91 WPA: group key handshake failed (RSN) after 4 tries
Thu Jul 23 11:48:21 2020 daemon.info hostapd: wlan0: STA f4:8c:50:f0:ac:f8 WPA: group key handshake failed (RSN) after 4 tries
Thu Jul 23 11:48:21 2020 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED f4:8c:50:f0:ac:f8
Thu Jul 23 11:48:26 2020 daemon.info hostapd: wlan0: STA bc:a9:20:93:a6:91 IEEE 802.11: deauthenticated due to local deauth request
Thu Jul 23 11:48:26 2020 daemon.info hostapd: wlan0: STA f4:8c:50:f0:ac:f8 IEEE 802.11: deauthenticated due to local deauth request
Thu Jul 23 11:48:56 2020 daemon.info hostapd: wlan0: STA bc:a9:20:93:a6:91 IEEE 802.11: authenticated
Thu Jul 23 11:48:56 2020 daemon.info hostapd: wlan0: STA bc:a9:20:93:a6:91 IEEE 802.11: associated (aid 1)
Thu Jul 23 11:48:56 2020 daemon.notice hostapd: wlan0: AP-STA-CONNECTED bc:a9:20:93:a6:91
Thu Jul 23 11:48:56 2020 daemon.info hostapd: wlan0: STA bc:a9:20:93:a6:91 WPA: pairwise key handshake completed (RSN)
Thu Jul 23 11:48:56 2020 daemon.info dnsmasq-dhcp[2628]: DHCPREQUEST(br-lan) 192.168.1.169 bc:a9:20:93:a6:91
Thu Jul 23 11:48:56 2020 daemon.info dnsmasq-dhcp[2628]: DHCPACK(br-lan) 192.168.1.169 bc:a9:20:93:a6:91 iPhonedeGabriel
Thu Jul 23 11:48:57 2020 daemon.warn odhcpd[1353]: DHCPV6 SOLICIT IA_NA from 00010001215c3246bca92093a691 on br-lan: ok fdad:806e:f5a0::42f/128
Thu Jul 23 11:48:58 2020 daemon.warn odhcpd[1353]: DHCPV6 REQUEST IA_NA from 00010001215c3246bca92093a691 on br-lan: ok fdad:806e:f5a0::42f/128
Thu Jul 23 11:49:29 2020 daemon.info hostapd: wlan0: STA bc:a9:20:93:a6:91 IEEE 802.11: disconnected due to excessive missing ACKs
Thu Jul 23 11:49:29 2020 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED bc:a9:20:93:a6:91
Thu Jul 23 11:49:32 2020 daemon.info hostapd: wlan0: STA bc:a9:20:93:a6:91 IEEE 802.11: authenticated
Thu Jul 23 11:49:32 2020 daemon.info hostapd: wlan0: STA bc:a9:20:93:a6:91 IEEE 802.11: associated (aid 1)
Thu Jul 23 11:49:34 2020 daemon.notice netifd: wan1 (4779): udhcpc: sending renew to 10.28.86.124
Thu Jul 23 11:49:34 2020 daemon.notice netifd: wan1 (4779): udhcpc: lease of 10.28.86.123 obtained, lease time 7200
Thu Jul 23 11:50:26 2020 daemon.info hostapd: wlan0: STA bc:a9:20:93:a6:91 IEEE 802.11: authenticated
Thu Jul 23 11:50:26 2020 daemon.info hostapd: wlan0: STA bc:a9:20:93:a6:91 IEEE 802.11: associated (aid 1)
Thu Jul 23 11:50:26 2020 daemon.notice hostapd: wlan0: AP-STA-CONNECTED bc:a9:20:93:a6:91
Thu Jul 23 11:50:26 2020 daemon.info hostapd: wlan0: STA bc:a9:20:93:a6:91 WPA: pairwise key handshake completed (RSN)
Thu Jul 23 11:50:27 2020 daemon.info dnsmasq-dhcp[2628]: DHCPDISCOVER(br-lan) bc:a9:20:93:a6:91
Thu Jul 23 11:50:27 2020 daemon.info dnsmasq-dhcp[2628]: DHCPOFFER(br-lan) 192.168.1.169 bc:a9:20:93:a6:91
Thu Jul 23 11:50:28 2020 daemon.info dnsmasq-dhcp[2628]: DHCPDISCOVER(br-lan) bc:a9:20:93:a6:91
Thu Jul 23 11:50:28 2020 daemon.info dnsmasq-dhcp[2628]: DHCPOFFER(br-lan) 192.168.1.169 bc:a9:20:93:a6:91
Thu Jul 23 11:50:30 2020 daemon.info dnsmasq-dhcp[2628]: DHCPREQUEST(br-lan) 192.168.1.169 bc:a9:20:93:a6:91
Thu Jul 23 11:50:30 2020 daemon.info dnsmasq-dhcp[2628]: DHCPACK(br-lan) 192.168.1.169 bc:a9:20:93:a6:91 iPhonedeGabriel
Thu Jul 23 11:50:32 2020 daemon.warn odhcpd[1353]: DHCPV6 SOLICIT IA_NA from 00010001215c3246bca92093a691 on br-lan: ok fdad:806e:f5a0::42f/128
Thu Jul 23 11:50:33 2020 daemon.warn odhcpd[1353]: DHCPV6 REQUEST IA_NA from 00010001215c3246bca92093a691 on br-lan: ok fdad:806e:f5a0::42f/128
Thu Jul 23 11:51:05 2020 daemon.info hostapd: wlan0: STA bc:a9:20:93:a6:91 IEEE 802.11: disconnected due to excessive missing ACKs.

Can you help me to understand what is the problem? Thanks.

hello try to force channel , and the 40mhz frequence of wifi , try another profil

essaie de forcer le choix du channel et aussi essai avec le 40mhz de wifi , tu as configurer quelque chose comme il ne faut pas

Thanks for your response. I have forced in channel 8, and 20mhz, because with 20mhz works better than 40 mhz.

https://openwrt.org/faq/disconnected_due_to_excessive_missing_acks

1 Like

Solution: /etc/config/wireless → @ config wifi-iface → add option disassoc_low_ack '0'

Sorry, but where I have to add this opttion? Really Thanks for the help.

screen76

Network > Wireless > Edit > Interface Configuration > Advanced Settings

1 Like

Thanks, I unchecked the Disassociate On Low Acknoledgment that was checked.

I will test this. Thanks!

I'm facing this problem too on both my mt7620a. any solution?

Did you try the one the Original Posted noted?

There was a bug fixed (included in master/snapshot in September)
mac80211: fix regression in station connection monitor optimization

which may affect this.

Not sure if this is in latest stable though

1 Like

yes yes. now my problem gone.

unfortunately no. doesn't solve my problem. how sad. this bug reported since 2016 if I remember. I have two devices using same chipset. both have same bug. here my log.

Tue Oct 27 20:42:58 2020 daemon.notice hostapd: wlan0: STA 70:3a:51:2d:8c:c6 IEEE 802.11: did not acknowledge authentication response
Tue Oct 27 20:43:10 2020 daemon.notice hostapd: wlan0: STA 70:3a:51:2d:8c:c6 IEEE 802.11: did not acknowledge authentication response
Tue Oct 27 20:43:18 2020 daemon.notice hostapd: wlan0: STA 70:3a:51:2d:8c:c6 IEEE 802.11: did not acknowledge authentication response
Tue Oct 27 20:44:18 2020 daemon.notice hostapd: wlan0: STA 18:01:f1:37:a4:56 IEEE 802.11: did not acknowledge authentication response
Tue Oct 27 20:44:26 2020 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED d0:f8:8c:c7:32:61
Tue Oct 27 20:44:41 2020 daemon.notice hostapd: wlan0: STA 18:01:f1:37:a4:56 IEEE 802.11: did not acknowledge authentication response
Tue Oct 27 20:44:44 2020 daemon.notice hostapd: wlan0: STA 18:01:f1:37:a4:56 IEEE 802.11: did not acknowledge authentication response

The disconnected due to excessive missing ACKs is something different than "did not acknowledge authencication response". The former is that the STA does not send ACK frames and hence the AP thinks the client is gone. The latter looks like either the AP or the STA is not configured right, or not supporting the same things. Are you by any chance using WPA2/WPA3 mixed mode? Avoid that, because not all clients may tolerate this.

thank you sir for the replay. I don't use any encryption on my WiFi.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.