Idiot's guide needed. Virgin media super hub and hh5a (SOLVED)

Unfortunately I may have bitten off more than I can chew. I am a total novice with openwrt.
I have bought a BT Home hub 5 version a with openwrt preinstalled. I have virgin media internet with a super hub 2.
I basically want to connect my hh5a to my super hub with an Ethernet cable so I can have a separate connection which will send all traffic through a vpn (openvpn is also installed).
The super hub has an ip address of
The hh5a when connected to the laptop by Ethernet (lan port 2) has an ip address of I can enter the router and change things using luci.
The problems start when I then connect the super hub to the hh5a. If I put the Ethernet cable into lan port 1 my laptop still connects to the internet but I can no longer communicate with the hh5a by going to
If I connect the Ethernet into the red wan port I can no longer connect to the internet.
What I need is an idiot's step by step guide on how to set it all up and configure it all. Does anyone know of one I could watch or read so I can get it all working please. I wasn't expecting this level of complexity.
Thanks in advance.

In general there is a lot of great information about the BT Home Hube 5 Type A at - including information about how to set it up for various (predominantly UK based) ISPs (should you desire to replace your ISP modem-router), but it also describes how to disable/ ignore the xDSL modem port and switch over to its WAN (xwan) port instead.

More specific to your question, it seems as if you were using the same subnet ( on both WAN and LAN, this isn't a valid configuration for routing/ firewall and the like, you need to configure one of your subnets differently (e.g.

As pointed out by @slh, it seems like all you need to do is reconfigure the HH5a so it uses the red ethernet WAN port instead of the default grey DSL port. See section 9.3 of the aforementioned installation guide.

See also the openvpn client guide for HH5a if you wish to install openvpn from scratch. You won't get more than 10 mbps through the openvpn connection btw.

Thank you both.
I have disabled the dsl and enabled the red wan port and it works just as I want it too.