IB-AC509 USB to Ethernet Adapter

How to find a compatible driver? Appreciate.

Probably kmod-usb-net-asix and/ or kmod-usb-net-asix-ax88179.

1 Like

I tried all 3 combinations and checked with ifconfig to see eth1 but had no success so far.

opkg update && opkg install usbutils && lsusb
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 004: ID 0b95:772b ASIX Electronics Corp. AX88772B
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

no success and tried again all 3 combinations and due diligence reboot.

opkg list-installed | grep '^kmod-usb'
kmod-usb-core - 4.14.180-1
kmod-usb-hid - 4.14.180-1
kmod-usb-net - 4.14.180-1
kmod-usb-net-asix - 4.14.180-1

Is ifconfig a valid command to find eth0 and eth1?

If so, should I buy another adapter?

I forgot to mention that I am on a Raspberry Pi, if that matters.

looks like you might be missing a usb2/3 module dwc2? it should have been included in a default install...

I took the image from here and have not made any modifications due to lack of knowledge, see see also Raspberry 3 B post-install IP issue.

How to find out what happened to dwc2?

ok, i'm probably wrong then

AX88772C does not seem to be supported :slightly_frowning_face:

According to that thread, 0b95:772b (AX88772B) should be supported by the asix kmod.

Note that it is a 100 Mb chip, so you may consider buying a new adapter anyway.

I just bought a ASIX MCS7830 100Mb which is guaranteed to work with the RPi 3 in order to gather experience.

The plan is to move to RPi 4 when the firmware is available and get an USB 3 / 1Gb adapter for it. Do you have any recommendation which chip will be most likely first and best supported?

An adapter supported by this module seems a good choice for USB 3 & Gigabit.