I2c-gpio-custom doesn't work on ARV7518PW (Lantiq Xway/Danube)

I was trying to get an i2c bus going on the free gpio's on the arv7518pw.
The problem I'm facing is that if I do an " insmod i2c-gpio-custom bus0=0,25,26 ", kernel reports
Custom GPIO-based I2C driver version 0.1.1
but not followed with
i2c-gpio i2c-gpio.X: using pins 25 (SDA) and 26 (SCL)
as it should, and of course there is no i2c-0 device in /dev. Of course, many different combinations of pins were tried, but with the same result.
This happens with both, lede-17.01 and snapshot (r5953), but not with an older openwrt AA build I made, the bus was created fine.
Could this be because pinctrl was enabled for xway on kernels >= 4.4? If so, what do I do?
Thanks in advance :slightly_smiling_face:

Just a follow-up, since the problem was human error, and it could help someone with the same issue.
I never saw what the gpio chip base was at /sys/class/gpio. Turns out the gpio chip I was looking for was actually gpiochip480, so to get pin 25 to be SCL and 26 to be SDA on bus 0, I had to do
insmod i2c-gpio-custom bus0=0,505,506
Basically adding the pin number to the base of the gpio chip. After that you get a nice kernel message:
i2c-gpio i2c-gpio.0: using pins 506 (SDA) and 505 (SCL)
You get a /dev/i2c-0 entry, and it works fine!

Also my usual problem so follow-up posts like this are really helpful.