I225-V Drivers not installed - No internet

It would be nice if 2.5G drivers were installed in the image however they are not and the device only has 2.5G nics and no internet. I need to install the kmod-igc drivers but I can't figure out how to do so. The device is new and has an internal SSD. I created a USB stick using Finnix and booted the device and installed an openwrt x86 image to the drive. It boots up fine but with no internet/intranet access. Could someone please give me step instructions to get the drivers installed? I would very much appreciate it. I read the other posts that are related to this, but the help was given as if the person was a unix admin - which I am not.

BTW - I have internet when the device is booted from the USB stick so I'm sure the nics are working. I just don't know how to download to the SSD from the USB.

  • Copy files to drive
  • Use firmware image builder and have drivers installed

Thanks for your reply however I need a little more explanation. I don't know how to copy files to the drive. I found the command in another thread but where do I get the files? Where do I put them to copy? Once they are copied, will opkg install them?

Copy/paste if using another machine or LiveUSB/CD...or download, copy, paste.

From: https://downloads.openwrt.org/

For your architecture/target platform.

All right - I found a file named kmod-igc_5.10.111-1_x86_64.ipk and downloaded it to my Mac. I can put the Finnix USB stick in my Mac and I see all the files/folders. Where do I copy it?

I have opened a vm copy of Linux Mint on my Mac and plugged in the Finnix USB stick. There are 4 folders in there - Boot, isolinux, EFI, Live.

Try putting them in /root of the openwrt drive.

Then opkg install /root/kmod-igc_5.10.111-1_x86_64.ipk via ssh.

1 Like

???

Is this OpenWrt?

No, the USB stick that has Finnix installed on it. I have ZERO connection to this PC on the network

Ummm, you need to copy to the OpenWrt...so not sure how that helps you.

Then you need physical drive access to transfer the file, because I don't think the packages for flash drive access are included in the image.

Catch 22.

1 Like

Great Idea but since I have no network connection to this PC, I have to put them on a USB stick to get them in the computer.

@hanzs , use this method:

No, you boot from LiveCD...or put the HDD in another machine that does boot.

It's the same as any other computer.

Ok - Live USB is the only thing I can do. I have no drive access and since it's a mSATA and the device is new and I don't want to take it apart to get physical access to the drive.

1 Like

You wrote openwrt to the mSATA drive, so there was/is some kind of access?

1 Like

Yes, I explained that in the original post. I put a linux distro (Finnix) on a USB drive and booted from the USB drive. Used wget and downloaded and installed openwrt to the mSata.

I can download the kmod driver on the Finnix USB LiveUSB, but I don't know the command to transfer it to the mSata. I just tried it and crashed the mSATA

I just got this device yesterday and it had pfsense on it. Maybe I should have left it but I had been using Openwrt and was used to it.

I can ssh into the device with Finnix running and I have a connection to the internet. The mSATA is sda and the USB is sdb

When in Finnix.

mount /dev/sda2 /mnt
cd /mnt/root

wget the ipk

sda1 and .../boot probably works just as well.

1 Like

So, we're suggesting you do the same thing.

  • Ummm...how about the copy command (cp)?
  • Or...just copy/paste with a GUI file manager???

Also:

(I'm starting to think this is becoming difficult for you due to frustration...take a break...maybe get some coffee...return in a few minutes. :coffee: :person_in_lotus_position: :pray: :sleeping_bed: )

OK - That worked! Now I will reboot the device to the mSATA and attempt to install the .ipk file

Fingers X:ed, if you're unlucky, there will be dependencies, and you'll have to redo it, and grab additional ipks.

If you have several NICs, the wan and lan port(s) might get reversed during hw probe.

What device is it, btw?

The device is a 4 port I225-V J4125 firewall appliance.

Ok - I checked and the file is in the root folder. If I run opkg install . I get error opkg_install_cmd Cannot install package kmod-igc