I was following the flashing guide for Tp-Link TD-W8970 and (I think) I bricked it

I'm not sure where should I post this, so if the moderator knows where to place it, please move it.
Yesterday I was trying to install OpenWRT to my Tp-Link TD-W8970, first following the guide here - https://openwrt.org/toh/tp-link/td-w8970_v1#installation_without_opening_the_case_web_interface_hack and from the step 8 I continued to follow the forum post guide here - https://forum.archive.openwrt.org/viewtopic.php?id=42380&p=13#p340785
Note: I tried "SSID Config Injection" and it didn't work so I changed back the SSID to other normal string and I followed the StatPost chapter and inside, the python procedure.
I followed every step in both guides, and also I backed up mtd0 to mtd6 and conf.bin . I have:
Then, when I executed the following command:

cat /var/usbdisk/sda1/td-w8970/openwrt-lantiq-xrx200-TDW8970-sysupgrade.image > /dev/mtdblock1

It gave me an error (sorry, I didn't copy it to anywhere, I don't have a clue about the error, only I remember that it was an error.).
From then,The router is unresponsive. For example, The power LED doesn't blink, it's permanently ON. I have tried the failsafe mode of the router's web page and also generic failsafe mode and factory reset. I also tried recovery mode a bit but I didn't finish because I didn't know if it doesn't work because of the router or I'm not doing well.
So now, I think it's bricked. is it?
If it's necessary to open the case and connect the serial interface, I can.
Please, can anybody give me any clue about what can be the problem? should I be sure that it's bricked? Is there any solution I can do apart from debricking it?
And, if it's bricked, Can you please give me a little of help to debrick it? the debricking guide in the router web page is difficult, I don't understand it.
Thanks in advance