I want get network from wifi and spread it with wifi

hello
i want get internet from wifi and connect vpn and then spread it using wifi, its possible?
my router already has this option on lan, mean i can connect network to it, then get output with vpn , but now i want get internet using wifi and spread it

something like extender

its possible with openwrt? how?

Thanks for your helps

https://openwrt.org/docs/guide-user/network/wifi/connect_client_wifi

1 Like
  • Set the Mode to Legacy if you are connecting to a Wi-Fi g network, or N if you are connecting to a Wi-Fi n (and so on).

  • Set the Width to the same value that you set on the Wi-Fi you are connecting to (to avoid bottlenecking the connection for no reason).

how i can make sure wafi connecting to it is N or g?
and how i can understand width of waifi connecting to it?

Thanks

After you scan and connect, both values are shown because the AP stipulates both. (so pay attention to both everything and write them everything down)
Then you just accommodate.

Travelmate package is also a good idea.

4 Likes

That was my first thought because the dependencies make this so much easier; even if you never use Travelmate but I thought more experienced posts would, of course, be thinking outside my box.

And the Relayd package too.
Also, even if not used.

unfortunately it cant found any wifi, do you know why?
screenshot:

but in radio0 i can found, can i use radio0 instead of radio1?

Show me Network/wireless/overview

Redact any identifiers; point to the device you just failed to scan with.

Also:

You edited without making the edit conspicuous.

Please do not do that.
And I do not know yet.

:spiral_notepad: Please post the cat calls and he screen shot I requested.

root@By-AmirHossein:~# ubus call system board
{
	"kernel": "5.15.150",
	"hostname": "By-AmirHossein",
	"system": "ARMv7 Processor rev 2 (v7l)",
	"model": "Linksys WRT1900AC v1",
	"board_name": "linksys,wrt1900ac-v1",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "23.05.3",
		"revision": "r23809-234f1a2efa",
		"target": "mvebu/cortexa9",
		"description": "OpenWrt 23.05.3 r23809-234f1a2efa"
	}
}

root@By-AmirHossein:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fda9:b123:368a::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config device
	option name 'lan1'
	option macaddr '94:10:3e:90:65:49'

config device
	option name 'lan2'
	option macaddr '94:10:3e:90:65:49'

config device
	option name 'lan3'
	option macaddr '94:10:3e:90:65:49'

config device
	option name 'lan4'
	option macaddr '94:10:3e:90:65:49'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.27.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option delegate '0'

config device
	option name 'wan'
	option macaddr '94:10:3e:90:65:49'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option peerdns '0'
	option dns '1.1.1.1'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'
	option peerdns '0'
	option dns '2001:4860:4860::8888'

root@By-AmirHossein:~# 
root@By-AmirHossein:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/soc:pcie@82000000/pci0000:00/0000:00:02.0/0000:02:00.0'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option country 'FR'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'link2'
	option encryption 'psk2'
	option macaddr '94:10:3e:90:65:4a'
	option key 'xxxxx'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'soc/soc:pcie@82000000/pci0000:00/0000:00:03.0/0000:03:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option disabled '1'
	option country 'FR'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
	option macaddr '94:10:3e:90:65:4b'

root@By-AmirHossein:~# 
root@By-AmirHossein:~# cat /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'
	option filter_aaaa '0'
	option filter_a '0'
	option localuse '1'
	option rebind_domain 'www.ebanksepah.ir 
my.irancell.ir'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

root@By-AmirHossein:~# 
root@By-AmirHossein:~# cat /etc/config/firewall

config defaults
	option syn_flood '1'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include 'passwall'
	option type 'script'
	option path '/var/etc/passwall.include'
	option reload '1'

config include 'passwall_server'
	option type 'script'
	option path '/var/etc/passwall_server.include'
	option reload '1'

root@By-AmirHossein:~#

Thanks

Please read every word.
If you fail to follow instructions or argue, most of the community will walk away from your thread.
Me?
I'll bitch; maybe 3 times.

:yawning_face: :yawning_face: :yawning_face: :disappointed: :zzz: :zzz: :zzz: :sleeping: :sleeping: :sleeping:

1 Like

sorry, ill be carefull from now
i edited details post, please see it

i hope its what you requested.

Thanks for your helps.

Te existing router - is it OpenWRT or some CPE given for free?

Ideally you want all clients in same DHCP segment with same access point names.
If provider router supports WDS that is way to go otherwise see below.

Less ideally various access points across home where you always lose connection changing access point. Connect uplink wwan, then just have other access point lan side.

For setup - you need to set country and save it before scanning.For ch12-13 or 42+. If you have a mobile data you can prime up tethering in respective band to confirm scan works.

2 Likes

It is but I'm on EDT and this is my 25th hour.

So, it will help anyone that would ask for it all.

Just hang tight.

1 Like

Did you get it working?
Looks like @brada4 gave you good advice.

Let OP try out over weekend.