I think I broke my "WD MY NET N750) while installing openwrt

P0lease Help! I got a WD MY Net N750 and proceeded to install openwrt firmware on it.

1)Went into the admin (
2)selected the right openwrt software and installed it
3)it took about 3 mins to install and when it finished i went to
4)it took me to the luci interface -- good job -- i configured it for my network
5)i unplugged it and tried to connect the N750 router to my home router
6)went on the computer and tried to access the router
7)couldn't connect to it... i went to the router and noticed only the power light is blinking
8)I unplugged the router and connected it directly to my laptop
9)noticed that my laptop wasn't pulling an ip address: ipconfig /release ; ipconfig/renew ......... ......nothing all i got was the apipa 169...***

10)I'm new to openwrt --but i'm familair with linux and networking... any help will be greatly appreciated.

Thanks in advance

@mickdon, welcome to the community!

First, I would try resetting it by holding the reset button for about 30 seconds.

Then if that doesn't work, simply proceed to flash OpenWrt as if you used the WD Emergency Recovery to do a fresh flash.

From your description, I see no other issues...

I wonder if the failsafe when changing IP is causing you issues. Perhaps you should change the IP via SSH.

vi /etc/config/network

Then reboot or

/etc/init.d/network reload

1 Like

@lleachii Thank you for your trying . I tried pressing the reset button for one minute and it didn't seem to do anything.
For your second suggestion, I can't ssh into it because the default IP ( address isn't working anymore. So when I try using putty it just times out.
In the article you sent I might have broken the router because I didn't complete the process. when I saw the luci interface I unplugged the router while I should have flashed it once more :frowning:
Do you have any other suggestion I can try ?
Thank you

Too long, probably put it in Emergency Mode anyway.



Start again...I can't imagine it erases the emergency procedure...

Follow the exact procedure to flash OpenWrt anew.

1 Like

Hi the good news is it's very very hard to brake this router. :slight_smile:

Look here under installation:
You have to flash twice.

1 Like

Thanks guys for trying. But it looks like this router is broken... i tried for a while, left it, and tried again. but it just won't boot. Think i broke the flash.

Seems to me you didn't follow the instructions correctly to gain access to recovery mode.

Configure your computer's ethernet port to static IP (really any address in the 192.168.1.* range except is fine) and connect it to a LAN port on the router.

Have you done that part? Please read the steps carefully, for both flashing and emergency procedure. State what you've done exactly so we can spot potential mistakes.

I'm pretty sure it isn't broken though. There's always the possibility to set up a serial connecting to see whats going on (needs additional USB-TTL converter and opening up your N750).

1 Like

As pointed out by @vuhuy , have you tried completing the whole installation from the beginning ?

ie. can you get into "Emergency Room" web page using Reset button to load the firmware?

Using a paperclip or a similarly blunt but thin object, press and hold the reset button through the hole marked “Reset” on the bottom of the router. While keeping this button pressed, turn the router on. Hold the reset button until the power LED starts flashing slowly (this takes slightly less than 10 seconds), you can then release the reset button.

I notice Western Digital seem to have removed all references for their MyNet router products. I can't even find their firmware download page.

I still have copies of the original MyNet N750 firmwares if you are able to get into "Emergency Room".

1 Like

The instructions say "about 10 seconds".

I also agree with @vuhuy - that it doesn't seem you've followed the procedure...waiting a while is not a part of it...and I thought we agreed it won't boot, so you have to use the Emergency Recovery.

  • Also, you need a very thin object to press/hold the reset button (e.g. a SIM card ejector)
  • BTW, the reset button is on the bottom of the device

Other than that, the instructions on the Wiki will cause a device to enter the "Emergency Room" recovery. This is the same procedure used to initially flash OpenWrt.


If you purchased your N750 new, the CD includes the OEM firmware.

I recently purchased a used WD My Net N750 to supplement my existing one.  I screwed up by only flashing the factory image and then not uploading the sysupgrade image, contrary to what the installation instructions said to do.

This resulted in the router's power light just blinking and not giving out a DHCP address -- just like @mickdon's opening comment in this thread.

Using the hidden reset button, I was able to get to the device's "Emergency Room" web page.  Attempts to upload the OEM firmware seemed to fail, though.  I would choose the file, click the Upload button and within 5-10 seconds, my web browser would display an "Unable to connect" message.  The power light would continue to blink as if nothing was happening.  Visiting again just showed the same Emergency Room web page.

I deduced that something was not allowing the OEM firmware to upload, normally, through the Emergency Room web page.  After looking at its source, I came up with this curl command -- whose output, as you can see -- showed success:

$ curl --verbose -F Upload=@My_Net_N750_1.01.04.bin
*   Trying
* Connected to ( port 80 (#0)
> POST /up.htm HTTP/1.1
> Host:
> User-Agent: curl/7.71.1
> Accept: */*
> Content-Length: 11456861
> Content-Type: multipart/form-data; boundary=------------------------b464fe85bb4f01cc
> Expect: 100-continue
* Done waiting for 100-continue
* We are completely uploaded and fine
* Received HTTP/0.9 when not allowed
* Closing connection 0
curl: (1) Received HTTP/0.9 when not allowed

Although I really had to be patient for the OEM firmware to boot up -- about 5 minutes -- it did, eventually.  From there, I was able to upload the factory OpenWRT image, and then the sysupgrade one. I now have a working My Net N750 running OpenWRT!